diff mbox series

[bug#53779,v2,2/6] gnu: iwd: Remove reference to %outputs.

Message ID fc4732e5453d3f1023025e59cce9d3557084550d.1644243309.git.simon@simonsouth.net
State Accepted
Headers show
Series gnu: iwd: Build from Git; update to 1.24. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon South Feb. 7, 2022, 2:26 p.m. UTC
* gnu/packages/networking.scm (iwd)[arguments]: Remove reference to %outputs
by using a gexp.
---
 gnu/packages/networking.scm | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 4258a14968..ef0ae12e49 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3580,16 +3580,15 @@  (define-public iwd
      (list pkg-config python python-docutils openssl))
     (arguments
      `(#:configure-flags
-       (let ((dbus (assoc-ref %outputs "out")))
-         (list "--disable-systemd-service"
-               "--enable-external-ell"
-               "--enable-hwsim"
-               "--enable-tools"
-               "--enable-wired"
-               "--localstatedir=/var"
-               (string-append "--with-dbus-datadir=" dbus "/share/")
-               (string-append "--with-dbus-busdir="
-                              dbus "/share/dbus-1/system-services")))
+       ,#~(list "--disable-systemd-service"
+                "--enable-external-ell"
+                "--enable-hwsim"
+                "--enable-tools"
+                "--enable-wired"
+                "--localstatedir=/var"
+                (string-append "--with-dbus-datadir=" #$output "/share/")
+                (string-append "--with-dbus-busdir="
+                               #$output "/share/dbus-1/system-services"))
        #:phases
        (modify-phases %standard-phases
          (add-after 'configure 'patch-Makefile