diff mbox series

[bug#53779,v2,5/6] gnu: ell: Update to 0.48.

Message ID 3ee4b75424261845377ff6eef04cac61c5e8b88b.1644243309.git.simon@simonsouth.net
State Accepted
Headers show
Series gnu: iwd: Build from Git; update to 1.24. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon South Feb. 7, 2022, 2:26 p.m. UTC
* gnu/packages/linux.scm (ell): Update to 0.48.
[arguments]: Remove obsolete "fix-dbus-tests" phase.
---
 gnu/packages/linux.scm | 14 ++------------
 1 file changed, 2 insertions(+), 12 deletions(-)

Comments

Ludovic Courtès Feb. 8, 2022, 10:48 p.m. UTC | #1
Hi again,

Simon South <simon@simonsouth.net> skribis:

> * gnu/packages/linux.scm (ell): Update to 0.48.
> [arguments]: Remove obsolete "fix-dbus-tests" phase.

I noticed this test failure on powerpc64le-linux:

--8<---------------cut here---------------start------------->8---
================================
   ell 0.48: ./test-suite.log
================================

# TOTAL: 40
# PASS:  38
# SKIP:  0
# XFAIL: 0
# FAIL:  2
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: unit/test-dbus-message-fds
================================

launching dbus-daemon
dbus-daemon process 16430 created
dbus-daemon[16430]: Failed to start message bus: Failed to bind socket "/tmp/ell-test-bus": Address already in use
process 16430 terminated with status=256

Disconnected from DBus
FAIL unit/test-dbus-message-fds (exit status: 134)

FAIL: unit/test-dbus-properties
===============================

launching dbus-daemon
dbus-daemon process 16445 created
dbus-daemon[16445]: Failed to start message bus: Failed to bind socket "/tmp/ell-test-bus": Address already in use
process 16445 terminated with status=256

Disconnected from DBus
FAIL unit/test-dbus-properties (exit status: 134)
--8<---------------cut here---------------end--------------->8---

(From <https://ci.guix.gnu.org/build/469659/log/raw>.)

This makes me think that perhaps we need #:parallel-tests? #f, WDYT?

Ludo’.
Simon South Feb. 9, 2022, 2:51 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:
> This makes me think that perhaps we need #:parallel-tests? #f, WDYT?

That seems right; I can reproduce the failure by building just the three
D-Bus-related tests together in parallel.

I'll follow up with a patch.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 138eab5ed2..1c76d37166 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8362,7 +8362,7 @@  (define-public wireplumber
 (define-public ell
   (package
     (name "ell")
-    (version "0.46")
+    (version "0.48")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -8371,18 +8371,8 @@  (define-public ell
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "15hwqicmll23cbrj13h3wd4lgrby416ap7l6w0434jsza4s4yv82"))))
+                "0lxjizby3zdyhzad5a0gbz4m2pp44jf1j4l1pn18d04rw9mr2gqy"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-dbus-tests
-           (lambda _
-             (substitute* '("unit/test-dbus-message-fds.c"
-                            "unit/test-dbus-properties.c"
-                            "unit/test-dbus.c")
-               (("/usr/bin/dbus-daemon") (which "dbus-daemon")))
-             #t)))))
     (inputs
      (list dbus))
     (native-inputs