diff mbox series

[bug#63765,v3,2/8] gnu: utfcpp: Update to 3.2.3.

Message ID f6f12997b618de020bb03f3ccc6dfffd07450a55.1687500984.git.hako@ultrarare.space
State New
Headers show
Series [bug#63765,v3,1/8] gnu: Add ftest-for-utfcpp. | expand

Commit Message

Hilton Chain June 23, 2023, 6:24 a.m. UTC
* gnu/packages/textutils.scm (utfcpp): Update to 3.2.3.
[arguments]: Remove arguments, then...
<#:phases>: ...Add 'unpack-ftest.
* gnu/packages/games.scm (warzone2100)<#:phases>: Adjust 'fix-utfcpp-include.
* gnu/packages/video.scm (mkvtoolnix)<#:phases>: Add 'fix-utfcpp-include.
---
 gnu/packages/games.scm     |  2 +-
 gnu/packages/textutils.scm | 20 +++++++-------------
 gnu/packages/video.scm     |  5 +++++
 3 files changed, 13 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 83704dd720..9dbf5a3739 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5510,7 +5510,7 @@  (define-public warzone2100
                  (lambda _
                    (substitute* "lib/framework/wzstring.cpp"
                      (("<utfcpp/source/utf8.h>")
-                      "<utf8.h>"))))
+                      "<utf8cpp/utf8.h>"))))
                (add-after 'unpack 'link-tests-with-qt
                  (lambda _
                    (substitute* "tests/Makefile.am"
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 26d0234390..81b403d559 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -701,7 +701,7 @@  (define ftest-for-utfcpp
 (define-public utfcpp
   (package
     (name "utfcpp")
-    (version "2.3.5")
+    (version "3.2.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -710,20 +710,14 @@  (define-public utfcpp
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1gr98d826z6wa58r1s5i7rz7q2x3r31v7zj0pjjlrc7gfxwklr4s"))))
+                "00hzh39iddbc6nxg13813qd6d55g2kccwjf5dr96wykfhway9wbr"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:out-of-source? #f
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'install              ; no install target
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (include (string-append out "/include"))
-                    (doc (string-append out "/share/doc/" ,name)))
-               (copy-recursively "source" include)
-               (install-file "README.md" doc)
-               #t))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'unpack-ftest
+                 (lambda* (#:key native-inputs #:allow-other-keys)
+                   (copy-recursively #$ftest-for-utfcpp "extern/ftest"))))))
     (home-page "https://github.com/nemtrif/utfcpp")
     (synopsis "Portable C++ library for handling UTF-8")
     (description "UTF8-CPP is a C++ library for handling UTF-8 encoded text
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 55eab972b9..43ae3899f9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1048,6 +1048,11 @@  (define-public mkvtoolnix
              "--enable-precompiled-headers=no")
         #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-utfcpp-include
+           (lambda _
+             (substitute* "src/common/strings/utf8.cpp"
+               (("<utf8.h>")
+                "<utf8cpp/utf8.h>"))))
          (add-after 'unpack 'patch-relative-file-names
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))