diff mbox series

[bug#63765,v3,3/8] gnu: mbedtls-apache: Rename package to mbedtls-apache-lts.

Message ID a6073ea880d1f38e85300900d5df603812874712.1687500984.git.hako@ultrarare.space
State New
Headers show
Series [bug#63765,v3,1/8] gnu: Add ftest-for-utfcpp. | expand

Commit Message

Hilton Chain June 23, 2023, 6:24 a.m. UTC
* gnu/packages/tls.scm (mbedtls-apache-lts): New variable, formerly known as
"mbedtls-apache".
---
 gnu/packages/emulators.scm        | 2 +-
 gnu/packages/game-development.scm | 2 +-
 gnu/packages/hardware.scm         | 4 ++--
 gnu/packages/haxe.scm             | 6 +++---
 gnu/packages/irc.scm              | 2 +-
 gnu/packages/julia-jll.scm        | 2 +-
 gnu/packages/julia.scm            | 2 +-
 gnu/packages/linphone.scm         | 2 +-
 gnu/packages/linux.scm            | 2 +-
 gnu/packages/networking.scm       | 2 +-
 gnu/packages/search.scm           | 2 +-
 gnu/packages/tls.scm              | 6 +++---
 gnu/packages/video.scm            | 2 +-
 13 files changed, 18 insertions(+), 18 deletions(-)

Comments

Liliana Marie Prikler June 26, 2023, 6:59 p.m. UTC | #1
Am Freitag, dem 23.06.2023 um 14:24 +0800 schrieb Hilton Chain:
> * gnu/packages/tls.scm (mbedtls-apache-lts): New variable, formerly
> known as "mbedtls-apache".
Proper format is 
  (old-name): Rename from this…
  (new-name): … to this.
Also list the package updates in the ChangeLog as "Adjust accordingly".
> ---
>  gnu/packages/emulators.scm        | 2 +-
>  gnu/packages/game-development.scm | 2 +-
>  gnu/packages/hardware.scm         | 4 ++--
>  gnu/packages/haxe.scm             | 6 +++---
>  gnu/packages/irc.scm              | 2 +-
>  gnu/packages/julia-jll.scm        | 2 +-
>  gnu/packages/julia.scm            | 2 +-
>  gnu/packages/linphone.scm         | 2 +-
>  gnu/packages/linux.scm            | 2 +-
>  gnu/packages/networking.scm       | 2 +-
>  gnu/packages/search.scm           | 2 +-
>  gnu/packages/tls.scm              | 6 +++---
>  gnu/packages/video.scm            | 2 +-
>  13 files changed, 18 insertions(+), 18 deletions(-)
> 
> diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
> index be76f81ff4..52921e79a6 100644
> --- a/gnu/packages/emulators.scm
> +++ b/gnu/packages/emulators.scm
> @@ -341,7 +341,7 @@ (define-public dolphin-emu
>               libxi
>               libxrandr
>               lzo
> -             mbedtls-apache
> +             mbedtls-apache-lts
>               mesa
>               miniupnpc
>               openal
> diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-
> development.scm
> index aa99109cca..4131b85a20 100644
> --- a/gnu/packages/game-development.scm
> +++ b/gnu/packages/game-development.scm
> @@ -1964,7 +1964,7 @@ (define-public godot
>             libxi
>             libxinerama
>             libxrandr
> -           mbedtls-apache
> +           mbedtls-apache-lts
>             mesa
>             opusfile
>             pcre2
> diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
> index c23299d1db..d1ad38adbd 100644
> --- a/gnu/packages/hardware.scm
> +++ b/gnu/packages/hardware.scm
> @@ -703,7 +703,7 @@ (define-public hueplusplus
>      (arguments
>       `(#:tests? #f)) ;; Tests require Google's gtest and gmock
>      (inputs
> -     (list mbedtls-apache))
> +     (list mbedtls-apache-lts))
>      (synopsis "C++ library to control Philips Hue lights")
>      (description "Hueplusplus is a library for controlling Philips
> Hue lights.
>  Features:
> @@ -1069,7 +1069,7 @@ (define-public openrgb
>             hueplusplus
>             nlohmann-json
>             libusb
> -           mbedtls-apache
> +           mbedtls-apache-lts
>             qtbase-5))
>      (native-inputs
>       (list pkg-config
> diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
> index 6fc30ce02f..60495630b9 100644
> --- a/gnu/packages/haxe.scm
> +++ b/gnu/packages/haxe.scm
> @@ -78,7 +78,7 @@ (define-public neko
>                    apr-util
>                    gtk+-2
>                    libgc
> -                  mbedtls-apache
> +                  mbedtls-apache-lts
>                    (list mariadb "dev")
>                    (list mariadb "lib")
>                    openssl
> @@ -171,7 +171,7 @@ (define-public haxe
>                   (lambda _
>                     (invoke "make" "install"))))))
>      (inputs (list libuv
> -                  mbedtls-apache
> +                  mbedtls-apache-lts
>                    neko
>                    ocaml-extlib
>                    ocaml-luv
> @@ -255,7 +255,7 @@ (define-public hashlink
>                    libpng
>                    libuv
>                    libvorbis
> -                  mbedtls-apache
> +                  mbedtls-apache-lts
>                    mikktspace
>                    minimp3
>                    openal
> diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
> index b31bb6b11a..d442787d97 100644
> --- a/gnu/packages/irc.scm
> +++ b/gnu/packages/irc.scm
> @@ -748,7 +748,7 @@ (define-public inspircd
>       (list argon2
>             gnutls
>             libmaxminddb
> -           mbedtls-apache
> +           mbedtls-apache-lts
>             (list mariadb "dev")
>             openldap
>             openssl
> diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
> index 2320b03595..78ec186bf2 100644
> --- a/gnu/packages/julia-jll.scm
> +++ b/gnu/packages/julia-jll.scm
> @@ -1404,7 +1404,7 @@ (define-public julia-mbedtls-jll
>                ;; There's a Julia file for each platform, override
> them all
>                (find-files "src/wrappers/" "\\.jl$"))
>               #t)))))
> -    (inputs (list mbedtls-apache))
> +    (inputs (list mbedtls-apache-lts))
>      (propagated-inputs (list julia-jllwrappers))
>      (home-page
> "https://github.com/JuliaBinaryWrappers/MbedTLS_jll.jl")
>      (synopsis "Apache's mbed TLS binary wrappers")
> diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
> index ba54175822..82891525c2 100644
> --- a/gnu/packages/julia.scm
> +++ b/gnu/packages/julia.scm
> @@ -511,7 +511,7 @@ (define-public julia
>         ("libunwind" ,libunwind-julia)
>         ("libuv" ,libuv-julia)
>         ("llvm" ,llvm-julia)
> -       ("mbedtls-apache" ,mbedtls-apache)
> +       ("mbedtls-apache" ,mbedtls-apache-lts)
>         ("mpfr" ,mpfr)
>         ("openblas" ,openblas)
>         ("openlibm" ,openlibm)
> diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
> index 7d87ee602c..f26c5efd3c 100644
> --- a/gnu/packages/linphone.scm
> +++ b/gnu/packages/linphone.scm
> @@ -188,7 +188,7 @@ (define-public bctoolbox
>                 (with-directory-excursion "tester"
>                   (invoke "./bctoolbox_tester"))))))))
>      (inputs
> -     (list bcunit libdecaf mbedtls-apache))
> +     (list bcunit libdecaf mbedtls-apache-lts))
>      (synopsis "Belledonne Communications Tool Box")
>      (description "BcToolBox is an utilities library used by
> Belledonne
>  Communications software like belle-sip, mediastreamer2 and
> linphone.")
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 52fb883467..c13f220613 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -2262,7 +2262,7 @@ (define-public dislocker
>      (build-system cmake-build-system)
>      (arguments
>       '(#:tests? #f)) ;no test suite
> -    (inputs (list fuse mbedtls-apache))
> +    (inputs (list fuse mbedtls-apache-lts))
>      (synopsis "FUSE driver to read/write Windows BitLocker drives")
>      (description
>       "This package provides means to to read BitLocker encrypted
> diff --git a/gnu/packages/networking.scm
> b/gnu/packages/networking.scm
> index b0cdcdf6a3..58f8249a36 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -822,7 +822,7 @@ (define-public nng
>      (native-inputs
>       `(("ksh" ,oksh)))
>      (inputs
> -     `(("mbedtls" ,mbedtls-apache)))
> +     `(("mbedtls" ,mbedtls-apache-lts)))
>      (synopsis "Lightweight messaging library")
>      (description "NNG project is a rewrite of the scalability
> protocols library
>  known as libnanomsg, and adds significant new capabilities, while
> retaining
> diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
> index 3e3e8e00c6..a0640799bc 100644
> --- a/gnu/packages/search.scm
> +++ b/gnu/packages/search.scm
> @@ -373,7 +373,7 @@ (define-public dataparksearch
>         (list aspell
>               c-ares
>               libextractor
> -             mbedtls-apache
> +             mbedtls-apache-lts
>               postgresql
>               zlib))
>        (synopsis "Feature rich search engine")
> diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
> index 140932a809..fdf9121a6d 100644
> --- a/gnu/packages/tls.scm
> +++ b/gnu/packages/tls.scm
> @@ -940,7 +940,7 @@ (define-public perl-crypt-openssl-random
>  
>  ;; The "-apache" variant is the upstreamed prefered variant. A "-
> gpl"
>  ;; variant exists in addition to the "-apache" one.
> -(define-public mbedtls-apache
> +(define-public mbedtls-apache-lts
>    (package
>      (name "mbedtls-apache")
>      ;; XXX Check whether ‘-Wformat-signedness’ still breaks mbedtls-
> for-hiawatha
> @@ -980,7 +980,7 @@ (define-public mbedtls-apache
>  (define-public mbedtls-for-hiawatha
>    (hidden-package
>     (package
> -     (inherit mbedtls-apache)
> +     (inherit mbedtls-apache-lts)
>       (name "mbedtls-apache")
>       (version "2.26.0")
>       (source
> @@ -1002,7 +1002,7 @@ (define-public mbedtls-for-hiawatha
>                (("Wformat-truncation=2") "Wformat-truncation"))
>              #t))))
>       (arguments
> -      (substitute-keyword-arguments (package-arguments mbedtls-
> apache)
> +      (substitute-keyword-arguments (package-arguments mbedtls-
> apache-lts)
>          ((#:phases phases)
>           `(modify-phases ,phases
>              (add-before 'configure 'configure-extra-features
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index 43ae3899f9..1fe11dcc8a 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -3456,7 +3456,7 @@ (define-public obs
>        libxcomposite
>        libxkbcommon
>        luajit
> -      mbedtls-apache
> +      mbedtls-apache-lts
>        mesa
>        pciutils
>        pipewire

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index be76f81ff4..52921e79a6 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -341,7 +341,7 @@  (define-public dolphin-emu
              libxi
              libxrandr
              lzo
-             mbedtls-apache
+             mbedtls-apache-lts
              mesa
              miniupnpc
              openal
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index aa99109cca..4131b85a20 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1964,7 +1964,7 @@  (define-public godot
            libxi
            libxinerama
            libxrandr
-           mbedtls-apache
+           mbedtls-apache-lts
            mesa
            opusfile
            pcre2
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index c23299d1db..d1ad38adbd 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -703,7 +703,7 @@  (define-public hueplusplus
     (arguments
      `(#:tests? #f)) ;; Tests require Google's gtest and gmock
     (inputs
-     (list mbedtls-apache))
+     (list mbedtls-apache-lts))
     (synopsis "C++ library to control Philips Hue lights")
     (description "Hueplusplus is a library for controlling Philips Hue lights.
 Features:
@@ -1069,7 +1069,7 @@  (define-public openrgb
            hueplusplus
            nlohmann-json
            libusb
-           mbedtls-apache
+           mbedtls-apache-lts
            qtbase-5))
     (native-inputs
      (list pkg-config
diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
index 6fc30ce02f..60495630b9 100644
--- a/gnu/packages/haxe.scm
+++ b/gnu/packages/haxe.scm
@@ -78,7 +78,7 @@  (define-public neko
                   apr-util
                   gtk+-2
                   libgc
-                  mbedtls-apache
+                  mbedtls-apache-lts
                   (list mariadb "dev")
                   (list mariadb "lib")
                   openssl
@@ -171,7 +171,7 @@  (define-public haxe
                  (lambda _
                    (invoke "make" "install"))))))
     (inputs (list libuv
-                  mbedtls-apache
+                  mbedtls-apache-lts
                   neko
                   ocaml-extlib
                   ocaml-luv
@@ -255,7 +255,7 @@  (define-public hashlink
                   libpng
                   libuv
                   libvorbis
-                  mbedtls-apache
+                  mbedtls-apache-lts
                   mikktspace
                   minimp3
                   openal
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index b31bb6b11a..d442787d97 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -748,7 +748,7 @@  (define-public inspircd
      (list argon2
            gnutls
            libmaxminddb
-           mbedtls-apache
+           mbedtls-apache-lts
            (list mariadb "dev")
            openldap
            openssl
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 2320b03595..78ec186bf2 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1404,7 +1404,7 @@  (define-public julia-mbedtls-jll
               ;; There's a Julia file for each platform, override them all
               (find-files "src/wrappers/" "\\.jl$"))
              #t)))))
-    (inputs (list mbedtls-apache))
+    (inputs (list mbedtls-apache-lts))
     (propagated-inputs (list julia-jllwrappers))
     (home-page "https://github.com/JuliaBinaryWrappers/MbedTLS_jll.jl")
     (synopsis "Apache's mbed TLS binary wrappers")
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index ba54175822..82891525c2 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -511,7 +511,7 @@  (define-public julia
        ("libunwind" ,libunwind-julia)
        ("libuv" ,libuv-julia)
        ("llvm" ,llvm-julia)
-       ("mbedtls-apache" ,mbedtls-apache)
+       ("mbedtls-apache" ,mbedtls-apache-lts)
        ("mpfr" ,mpfr)
        ("openblas" ,openblas)
        ("openlibm" ,openlibm)
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 7d87ee602c..f26c5efd3c 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -188,7 +188,7 @@  (define-public bctoolbox
                (with-directory-excursion "tester"
                  (invoke "./bctoolbox_tester"))))))))
     (inputs
-     (list bcunit libdecaf mbedtls-apache))
+     (list bcunit libdecaf mbedtls-apache-lts))
     (synopsis "Belledonne Communications Tool Box")
     (description "BcToolBox is an utilities library used by Belledonne
 Communications software like belle-sip, mediastreamer2 and linphone.")
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 52fb883467..c13f220613 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2262,7 +2262,7 @@  (define-public dislocker
     (build-system cmake-build-system)
     (arguments
      '(#:tests? #f)) ;no test suite
-    (inputs (list fuse mbedtls-apache))
+    (inputs (list fuse mbedtls-apache-lts))
     (synopsis "FUSE driver to read/write Windows BitLocker drives")
     (description
      "This package provides means to to read BitLocker encrypted
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b0cdcdf6a3..58f8249a36 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -822,7 +822,7 @@  (define-public nng
     (native-inputs
      `(("ksh" ,oksh)))
     (inputs
-     `(("mbedtls" ,mbedtls-apache)))
+     `(("mbedtls" ,mbedtls-apache-lts)))
     (synopsis "Lightweight messaging library")
     (description "NNG project is a rewrite of the scalability protocols library
 known as libnanomsg, and adds significant new capabilities, while retaining
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 3e3e8e00c6..a0640799bc 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -373,7 +373,7 @@  (define-public dataparksearch
        (list aspell
              c-ares
              libextractor
-             mbedtls-apache
+             mbedtls-apache-lts
              postgresql
              zlib))
       (synopsis "Feature rich search engine")
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 140932a809..fdf9121a6d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -940,7 +940,7 @@  (define-public perl-crypt-openssl-random
 
 ;; The "-apache" variant is the upstreamed prefered variant. A "-gpl"
 ;; variant exists in addition to the "-apache" one.
-(define-public mbedtls-apache
+(define-public mbedtls-apache-lts
   (package
     (name "mbedtls-apache")
     ;; XXX Check whether ‘-Wformat-signedness’ still breaks mbedtls-for-hiawatha
@@ -980,7 +980,7 @@  (define-public mbedtls-apache
 (define-public mbedtls-for-hiawatha
   (hidden-package
    (package
-     (inherit mbedtls-apache)
+     (inherit mbedtls-apache-lts)
      (name "mbedtls-apache")
      (version "2.26.0")
      (source
@@ -1002,7 +1002,7 @@  (define-public mbedtls-for-hiawatha
               (("Wformat-truncation=2") "Wformat-truncation"))
             #t))))
      (arguments
-      (substitute-keyword-arguments (package-arguments mbedtls-apache)
+      (substitute-keyword-arguments (package-arguments mbedtls-apache-lts)
         ((#:phases phases)
          `(modify-phases ,phases
             (add-before 'configure 'configure-extra-features
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 43ae3899f9..1fe11dcc8a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3456,7 +3456,7 @@  (define-public obs
       libxcomposite
       libxkbcommon
       luajit
-      mbedtls-apache
+      mbedtls-apache-lts
       mesa
       pciutils
       pipewire