diff mbox series

[bug#63765,v3,4/8] gnu: mbedtls-apache-for-hiawatha: Use inherited source.

Message ID 75eabf89eba5fc57e953d8cbe9428e60f955b458.1687500984.git.hako@ultrarare.space
State New
Headers show
Series [bug#63765,v3,1/8] gnu: Add ftest-for-utfcpp. | expand

Commit Message

Hilton Chain June 23, 2023, 6:24 a.m. UTC
* gnu/packages/tls.scm (mbedtls-apache-for-hiawatha): Use inherited source.
[arguments]<#:phases>: Keep "-Wformat-signedness".
---
 gnu/packages/tls.scm | 25 -------------------------
 1 file changed, 25 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index fdf9121a6d..6d2dc8d0c3 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -943,8 +943,6 @@  (define-public perl-crypt-openssl-random
 (define-public mbedtls-apache-lts
   (package
     (name "mbedtls-apache")
-    ;; XXX Check whether ‘-Wformat-signedness’ still breaks mbedtls-for-hiawatha
-    ;; when updating.
     (version "2.28.0")
     (source
      (origin
@@ -981,26 +979,6 @@  (define-public mbedtls-for-hiawatha
   (hidden-package
    (package
      (inherit mbedtls-apache-lts)
-     (name "mbedtls-apache")
-     (version "2.26.0")
-     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-              (url "https://github.com/ARMmbed/mbedtls")
-              (commit (string-append "mbedtls-" version))))
-        (sha256
-         (base32 "0scwpmrgvg6q7rvqkc352d2fqlsx0aylcbyibcp1f1rsn8iiif2m"))
-        (file-name (git-file-name name version))
-        (modules '((guix build utils)))
-        (snippet
-         '(begin
-            ;; Can be removed with the next version.
-            ;; Reduce level of format truncation warnings due to false positives.
-            ;; https://github.com/ARMmbed/mbedtls/commit/2065a8d8af27c6cb1e40c9462b5933336dca7434
-            (substitute* "CMakeLists.txt"
-              (("Wformat-truncation=2") "Wformat-truncation"))
-            #t))))
      (arguments
       (substitute-keyword-arguments (package-arguments mbedtls-apache-lts)
         ((#:phases phases)
@@ -1011,9 +989,6 @@  (define-public mbedtls-for-hiawatha
                             (invoke "scripts/config.pl" "set" feature))
                           (list "MBEDTLS_THREADING_C"
                                 "MBEDTLS_THREADING_PTHREAD"))
-                ;; XXX The above enables code that breaks with -Werror…
-                (substitute* "CMakeLists.txt"
-                  ((" -Wformat-signedness") ""))
                 #t)))))))))
 
 (define-public dehydrated