diff mbox series

[bug#63765,v6,05/10] gnu: Add frozen.

Message ID f628b79bcdf017c94817a136b00b55bbb0ca845c.1691240736.git.hako@ultrarare.space
State New
Headers show
Series gnu: python-lief: Update to 0.13.2. | expand

Commit Message

Hilton Chain Aug. 5, 2023, 1:19 p.m. UTC
* gnu/packages/cpp.scm (frozen): New variable.
---
 gnu/packages/cpp.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 1a71c86c3c..5d1361173f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -567,6 +567,29 @@  (define-public fifo-map
 as ordering relation.")
     (license license:expat)))
 
+(define-public frozen
+  (let ((commit "5af40b3f9e03116aa2de4d55b53b9629e5988480")
+        (revision "8"))
+    (package
+      (name "frozen")
+      (version (git-version "1.1.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/serge-sans-paille/frozen")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "02snxdfmrzcqwnkazhlagsfamr3mcg10iskpz5l8yscckzvyhzfs"))))
+      (build-system cmake-build-system)
+      (home-page "https://github.com/serge-sans-paille/frozen")
+      (synopsis "Header-only, constexpr alternative to gperf for C++14")
+      (description
+       "Frozen is a header-only library that provides 0 cost initialization
+for immutable containers, fixed-size containers, and various algorithms.")
+      (license license:asl2.0))))
+
 (define-public json-dto
   (package
     (name "json-dto")