diff mbox series

[bug#63765,v6,08/10] gnu: Add melkor.

Message ID 5156b60a34961e48e9cba8fa9ba86990eb35cfa4.1691240736.git.hako@ultrarare.space
State New
Headers show
Series gnu: python-lief: Update to 0.13.2. | expand

Commit Message

Hilton Chain Aug. 5, 2023, 1:19 p.m. UTC
* gnu/packages/elf.scm (melkor): New variable.
---
 gnu/packages/elf.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index a100038f14..3ddb6c4064 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -28,6 +28,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages elf)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -340,3 +341,39 @@  (define-public libdwarf
 debugging information format.")
     ;; See https://www.prevanders.net/dwarflicense.html:
     (license (list lgpl2.1 gpl2 bsd-2))))
+
+(define-public melkor
+  (let ((commit "ac2495bef2a744e7931537e023b1129229b001c4")
+        (revision "8"))
+    (package
+      (name "melkor")
+      (version (git-version "1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/romainthomas/elf_fuzzer")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1czg0dgvzxcsi04myjvvdcl3vcf59d5l328ydmm01lh892wdf4dy"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list #:tests? #f                ;No tests.
+             #:make-flags
+             #~(list (string-append "CC=" #$(cc-for-target))
+                     (format #f "INSTALLPATH=~a/bin/" #$output))
+             #:phases
+             #~(modify-phases %standard-phases
+                 ;; No configure script.
+                 (delete 'configure)
+                 (add-before 'install 'create-/bin
+                   (lambda _
+                     (mkdir-p (string-append #$output "/bin")))))))
+      ;; Fork of <https://github.com/IOActive/Melkor_ELF_Fuzzer>
+      (home-page "https://github.com/romainthomas/elf_fuzzer")
+      (synopsis "ELF File Format Fuzzer")
+      (description
+       "Melkor is an intuitive and easy-to-use ELF file format fuzzer for
+finding functional and security bugs in ELF parsers.")
+      (license gpl3+))))