diff mbox series

[bug#63765,v6,06/10] gnu: Add boost-leaf.

Message ID cc0ed300b1209b36a68aeb44024c5bf829361537.1691240736.git.hako@ultrarare.space
State New
Headers show
Series gnu: python-lief: Update to 0.13.2. | expand

Commit Message

Hilton Chain Aug. 5, 2023, 1:19 p.m. UTC
* gnu/packages/boost.scm (boost-leaf): New variable.
---
 gnu/packages/boost.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d2b676cc73..9b522a54fb 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -42,6 +42,7 @@  (define-module (gnu packages boost)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
@@ -363,6 +364,38 @@  (define-public boost-for-mysql
        (delete "python-minimal-wrapper")))
     (properties '((hidden? . #t)))))
 
+(define-public boost-leaf
+  (package
+    (name "boost-leaf")
+    (version "1.82.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/boostorg/leaf")
+                    (commit (string-append "boost-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1awxidipj54rz82mk48axaajiy5na8qsglqrv9iqr50kvjil39z1"))))
+    (build-system meson-build-system)
+    (arguments
+     (list #:configure-flags
+           #~'("-Dleaf_enable_examples=false")
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'install
+                 (lambda _
+                   (mkdir-p #$output)
+                   (copy-recursively
+                    "../source/include"
+                    (string-append #$output "/include")))))))
+    (home-page "https://boostorg.github.io/leaf/")
+    (synopsis "C++11 error handling library")
+    (description
+     "@acronym{LEAF, Lightweight Error Augmentation Framework} is a lightweight
+error handling library for C++11.")
+    (license license:boost1.0)))
+
 (define-public boost-sync
   (let ((commit "e690de2d30e2f1649ff500c9a6f3539814994b1c")
         (version "1.55")