diff mbox series

[bug#68355,2/8] gnu: cross-gcc-toolchain: Use fixed name.

Message ID f4750efebd8ba6ea90a614744eebec8140443085.1704841447.git.jean@foundationdevices.com
State New
Headers show
Series guix: Add or1k-elf platform. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Jan. 9, 2024, 11:14 p.m. UTC
* gnu/packages/cross-base.scm (cross-gcc-toolchain) <name>: Always use
  gcc-cross- prefix regardless of TARGET having a C standard library or
  not.

Change-Id: I5cbe89c61e5bd324a385db17c27131ea5ef75669
---
 gnu/packages/cross-base.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Mathieu Othacehe Jan. 12, 2024, 8:25 p.m. UTC | #1
> * gnu/packages/cross-base.scm (cross-gcc-toolchain) <name>: Always use
>   gcc-cross- prefix regardless of TARGET having a C standard library or
>   not.
  ^
  no alignment here

> -    (name (string-append (package-name xgcc) "-toolchain"))
> +    ;; Using PACKAGE-NAME of XGCC is avoided here as there are platforms that still
> +    ;; need a toolchain but don't have a libc.

There is a 78 columns limit. If you are using Emacs, you can enable
whitespace mode to display the characters that are over the limit, then
use `fill-paragraph` to have Emacs fix it for you.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 6ee7b315d8..6abf07be17 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -745,7 +745,9 @@  (define* (cross-gcc-toolchain/implementation target
   "Returns PACKAGE that contains a cross-compilation tool chain for TARGET
 with XBINUTILS, XGCC and LIBC (if exists for TARGET)."
   (package
-    (name (string-append (package-name xgcc) "-toolchain"))
+    ;; Using PACKAGE-NAME of XGCC is avoided here as there are platforms that still
+    ;; need a toolchain but don't have a libc.
+    (name (string-append "gcc-cross-" target "-toolchain"))
     (version (package-version xgcc))
     (source #f)
     (build-system trivial-build-system)