diff mbox series

[bug#68355,1/8] guix: Add ork1-elf platform.

Message ID 577f930d63230d1308c15c10d6cbc50afe973a40.1704841447.git.jean@foundationdevices.com
State New
Headers show
Series guix: Add or1k-elf platform. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Jan. 9, 2024, 11:14 p.m. UTC
* Makefile.am (MODULES): Add guix/platforms/or1k.scm.

* doc/guix.texi: Document or1k-elf platform.

* guix/platforms/or1k.scm (or1k-elf): New variable.

Change-Id: I3f71a0fa97f1ebd2bbdbf6cd00a93b477a123648
---
 Makefile.am             |  1 +
 doc/guix.texi           |  6 ++++++
 guix/platforms/or1k.scm | 28 ++++++++++++++++++++++++++++
 3 files changed, 35 insertions(+)
 create mode 100644 guix/platforms/or1k.scm

Comments

Mathieu Othacehe Jan. 12, 2024, 8:22 p.m. UTC | #1
Hello,

This looks good and I have only cosmetic remarks.

> * Makefile.am (MODULES): Add guix/platforms/or1k.scm.
>
> * doc/guix.texi: Document or1k-elf platform.

No new line between those commit log entries.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/Makefile.am b/Makefile.am
index b64dcaa77c..deee38232f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -140,6 +140,7 @@  MODULES =					\
   guix/platforms/arm.scm                        \
   guix/platforms/avr.scm                        \
   guix/platforms/mips.scm                       \
+  guix/platforms/or1k.scm                       \
   guix/platforms/powerpc.scm                    \
   guix/platforms/riscv.scm                      \
   guix/platforms/x86.scm                        \
diff --git a/doc/guix.texi b/doc/guix.texi
index 395545bed7..8b32722d64 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -16902,6 +16902,7 @@  Cross-Compilation
    - i686-linux-gnu
    - i686-w64-mingw32
    - mips64el-linux-gnu
+   - or1k-elf
    - powerpc-linux-gnu
    - powerpc64le-linux-gnu
    - riscv64-linux-gnu
@@ -46093,6 +46094,11 @@  Supported Platforms
 from AVR Libc.
 @end defvar
 
+@defvar or1k-elf
+Platform targeting OpenRISC 1000 CPU without an operating system and without a
+C standard library.
+@end defvar
+
 @node System Images
 @chapter Creating System Images
 
diff --git a/guix/platforms/or1k.scm b/guix/platforms/or1k.scm
new file mode 100644
index 0000000000..bf983085c5
--- /dev/null
+++ b/guix/platforms/or1k.scm
@@ -0,0 +1,28 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix platforms or1k)
+  #:use-module (guix platform)
+  #:use-module (guix records)
+  #:export (or1k-elf))
+
+(define or1k-elf
+  (platform
+   (target "or1k-elf")
+   (system #f)
+   (glibc-dynamic-linker #f)))