diff mbox series

[bug#68355,6/8] gnu: make-crust-package: Use or1k-elf as target.

Message ID ccf911abd5f6c728a928e7ce421d9d78cf400d97.1704841447.git.jean@foundationdevices.com
State New
Headers show
Series guix: Add or1k-elf platform. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Jan. 9, 2024, 11:14 p.m. UTC
* gnu/packages/firmware.scm (make-crust-package): Use or1k-elf as the
  target.

Change-Id: I6c8bf053527f1e12e35402f18cebf8e75557c788
---
 gnu/packages/firmware.scm | 20 +++++++-------------
 1 file changed, 7 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 30422a573c..e62f29993a 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1210,13 +1210,13 @@  (define make-crust-package
       (build-system gnu-build-system)
       (arguments
        (list
+        #:target "or1k-elf"
         #:tests? #f                       ;no test suite
-        #:make-flags
-        #~(list "CROSS_COMPILE=or1k-elf-"
-                "V=1"
-                "HOSTAR=ar"
-                "HOSTCC=gcc"
-                "LEX=flex")
+        #:make-flags #~'("CROSS_COMPILE=or1k-elf-"
+                         "V=1"
+                         "HOSTAR=ar"
+                         "HOSTCC=gcc"
+                         "LEX=flex")
         #:phases
         #~(modify-phases %standard-phases
             (delete 'configure)
@@ -1230,13 +1230,7 @@  (define make-crust-package
                             (install-file file (string-append #$output
                                                               "/libexec")))
                           (find-files "." "(scp\\.bin|\\.config)$")))))))
-      ;; The firmware is cross-compiled using a "bare bones" compiler (no libc).
-      ;; Use our own tool chain for that.
-      (native-inputs
-       (list bison
-             (cross-gcc "or1k-elf")
-             (cross-binutils "or1k-elf")
-             flex))
+      (native-inputs (list bison flex))
       (home-page "https://github.com/crust-firmware/crust")
       (synopsis "System control processor firmware for Allwinner sunxi boards")
       (description "Crust improves battery life and thermal performance by