diff mbox series

[bug#69257,rust-team,v2,065/117] gnu: rust-postgres-protocol-0.6: Upgrade to 0.6.6.

Message ID f1c09a872ef50f35b29b8d2f5b442871fee8bde2.1714330022.git.herman@rimm.ee
State New
Headers show
Series Fix dependencies. | expand

Commit Message

Herman Rimm April 28, 2024, 6:55 p.m. UTC
* gnu/packages/crates-crypto.scm (rust-postgres-protocol-0.6): Update to
0.6.6.
[cargo-inputs]: Add rust-getrandom-0.2.  Replace rust-base64-0.13 with
0.21, rust-hmac-0.10 with 0.12, rust-md-5-0.9 with 0.10 and
rust-sha2-0.9 with 0.10.

Change-Id: Ieb73c5df86805ff146a0921b94f0c9cb15c997bf
---
 gnu/packages/crates-io.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8adaa126ac..71ca3aad4a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -55763,7 +55763,7 @@  (define-public rust-postgres-derive-0.4
 (define-public rust-postgres-protocol-0.6
   (package
     (name "rust-postgres-protocol")
-    (version "0.6.1")
+    (version "0.6.6")
     (source
       (origin
         (method url-fetch)
@@ -55771,20 +55771,20 @@  (define-public rust-postgres-protocol-0.6
         (file-name
          (string-append name "-" version ".tar.gz"))
         (sha256
-         (base32
-          "1wxzs78zvz00bh3bhbbp9hnq9hg77f8h5pzjmcy9481fsdq0ygpz"))))
+         (base32 "0855ijaw98nrx2lzx739wiydk2qyq9jcmw85l15splrw33pwbdj9"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
-       (("rust-base64" ,rust-base64-0.13)
+       (("rust-base64" ,rust-base64-0.21)
         ("rust-byteorder" ,rust-byteorder-1)
         ("rust-bytes" ,rust-bytes-1)
         ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
-        ("rust-hmac" ,rust-hmac-0.10)
-        ("rust-md-5" ,rust-md-5-0.9)
+        ("rust-getrandom" ,rust-getrandom-0.2)
+        ("rust-hmac" ,rust-hmac-0.12)
+        ("rust-md-5" ,rust-md-5-0.10)
         ("rust-memchr" ,rust-memchr-2)
         ("rust-rand" ,rust-rand-0.8)
-        ("rust-sha2" ,rust-sha2-0.9)
+        ("rust-sha2" ,rust-sha2-0.10)
         ("rust-stringprep" ,rust-stringprep-0.1))))
     (home-page "https://github.com/sfackler/rust-postgres")
     (synopsis "Low level Postgres protocol APIs")