diff mbox series

[bug#69257,rust-team,v2,104/117] WIP: gnu: Add rust-gdk4-wayland-0.7.

Message ID 144e6101e68fcb362f9bdf5e8e2efcdb5dcf6f66.1714330024.git.herman@rimm.ee
State New
Headers show
Series Fix dependencies. | expand

Commit Message

Herman Rimm April 28, 2024, 6:58 p.m. UTC
* gnu/packages/crates-gtk.scm (rust-gdk4-wayland-0.7): Add variable.

Change-Id: Iee8240f41c5a5b9162d420715caef3653a38a2e3
---
 gnu/packages/crates-gtk.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index caab0398ac..549828b578 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1008,6 +1008,36 @@  (define-public rust-gdk4-sys-0.7
     (description "This package provides FFI bindings of GDK 4.")
     (license license:expat)))
 
+(define-public rust-gdk4-wayland-0.7
+  (package
+    (name "rust-gdk4-wayland")
+    (version "0.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gdk4-wayland" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "04zkspjs1r6l4gj241p9xm2zmp91phm1khakw5jvsm8yy4pi1f8d"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-gdk4" ,rust-gdk4-0.7)
+                       ("rust-gdk4-wayland-sys" ,rust-gdk4-wayland-sys-0.7)
+                       ("rust-gio" ,rust-gio-0.18)
+                       ("rust-glib" ,rust-glib-0.18)
+                       ("rust-khronos-egl" ,rust-khronos-egl-5)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-wayland-backend" ,rust-wayland-backend-0.1)
+                       ("rust-wayland-client" ,rust-wayland-client-0.30)
+                       ("rust-xkb" ,rust-xkb-0.3))
+       #:cargo-development-inputs
+       (("rust-gir-format-check" ,rust-gir-format-check-0.1))))
+    (home-page "https://gtk-rs.org/gtk4-rs")
+    (synopsis "Rust bindings of the GDK 4 Wayland library")
+    (description
+      "This package provides Rust bindings of the GDK 4 Wayland library.")
+    (license license:expat)))
+
 (define-public rust-gio-0.18
   (package
     (name "rust-gio")