diff mbox series

[bug#69257,rust-team,v2,026/117] gnu: Add rust-konst-proc-macros-0.3.

Message ID 8baf68e3ed4545062003488573175d552d9534de.1714330021.git.herman@rimm.ee
State New
Headers show
Series Fix dependencies. | expand

Commit Message

Herman Rimm April 28, 2024, 6:54 p.m. UTC
* gnu/packages/crates-io.scm (rust-konst-proc-macros-0.3): Add variable.
(rust-konst-proc-macros-0.2): Inherit from rust-konst-proc-macros-0.3.
---
 gnu/packages/crates-io.scm | 23 +++++++++++++++++++----
 1 file changed, 19 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8b3083c71f..b8e789e763 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -36418,23 +36418,38 @@  (define-public rust-konst-macro-rules-0.2
     (description "Implementation detail of the konst crate.")
     (license license:zlib)))
 
-(define-public rust-konst-proc-macros-0.2
+(define-public rust-konst-proc-macros-0.3
   (package
     (name "rust-konst-proc-macros")
-    (version "0.2.11")
+    (version "0.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "konst_proc_macros" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0dxp8mdh3q9d044ql203way4fgbc50n3j3pi2j1x2snlcaa10klq"))))
+        (base32 "0hv07c8b0v8rlcwkf2n1fv46d5ldk8md344c5c6dc2ayqcfsna2f"))))
     (build-system cargo-build-system)
     (home-page "https://github.com/rodrimati1992/konst/")
     (synopsis "Implementation detail of the @code{konst} crate")
-    (description "Implementation detail of the @code{konst} crate.")
+    (description
+      "@code{konst-proc-macros} is an implementation detail of the
+@code{konst} crate.")
     (license license:zlib)))
 
+(define-public rust-konst-proc-macros-0.2
+  (package
+    (inherit rust-konst-proc-macros-0.3)
+    (name "rust-konst-proc-macros")
+    (version "0.2.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "konst_proc_macros" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0dxp8mdh3q9d044ql203way4fgbc50n3j3pi2j1x2snlcaa10klq"))))))
+
 (define-public rust-kqueue-1
   (package
     (name "rust-kqueue")