diff mbox series

[bug#66843,04/11] gnu: Add r-celestial.

Message ID eb3fb49b7e860d875ac331e89acf7b986ca4cd8e.1698749849.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#66843,01/11] gnu: Add r-r3cseq. | expand

Commit Message

Mădălin Ionel Patrașcu Oct. 31, 2023, 10:57 a.m. UTC
* gnu/packages/cran.scm (r-celestial): New variable.

Change-Id: I9ab9c6b6c79f2fb12d7391a75e7214bbeba675fc
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fe8014c381..cc3ac02599 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -305,6 +305,30 @@  (define-public r-changepoint
     ;; Any version of the GPL.
     (license license:gpl3+)))
 
+(define-public r-celestial
+  (package
+    (name "r-celestial")
+    (version "1.4.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "celestial" version))
+       (sha256
+        (base32 "1gls0qvr8mxz79lsmk76v253f747g0cqys8p8wjmpijs8r0pyr4z"))))
+    (properties `((upstream-name . "celestial")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-nistunits r-pracma r-rann))
+    (home-page "https://cran.r-project.org/package=celestial")
+    (synopsis
+     "Collection of common astronomical conversion routines and functions")
+    (description
+     "This package contains a number of common astronomy conversion routines,
+particularly the HMS and degrees schemes, which can be fiddly to convert between
+on mass due to the textural nature of the former.  It allows users to coordinate
+match datasets quickly.  It also contains functions for various cosmological
+calculations.")
+    (license license:gpl3)))
+
 ;; The package sources include multiple non-minified JavaScript files and the
 ;; v5.1.0 variant of d3.js.  The d3.js file is not minified.
 (define-public r-chromomap