diff mbox series

[bug#66843,10/11] gnu: Add r-coregx.

Message ID d2ec1406833de3b695c051f92150ec2bfaaf763f.1698749849.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#66843,01/11] gnu: Add r-r3cseq. | expand

Commit Message

Mădălin Ionel Patrașcu Oct. 31, 2023, 10:57 a.m. UTC
* gnu/packages/bioconductor.scm (r-coregx): New variable.

Change-Id: Ib54ba3c7bebdcc90748d4e4b0b2ce63b7f0fc1b8
---
 gnu/packages/bioconductor.scm | 46 +++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e2fd9c5016..091cf98b5c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4422,6 +4422,52 @@  (define-public r-cellid
 enrichment in single cell data.")
     (license license:gpl3)))
 
+(define-public r-coregx
+  (package
+    (name "r-coregx")
+    (version "2.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "CoreGx" version))
+       (sha256
+        (base32 "09pv117g8sxhrij960mparrz1r9vx8s20gmpvn1h667kl1bc0jm9"))))
+    (properties `((upstream-name . "CoreGx")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-bench
+           r-biobase
+           r-biocgenerics
+           r-biocparallel
+           r-bumpymatrix
+           r-checkmate
+           r-crayon
+           r-data-table
+           r-glue
+           r-lsa
+           r-matrixgenerics
+           r-multiassayexperiment
+           r-piano
+           r-rlang
+           r-s4vectors
+           r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/CoreGx")
+    (synopsis
+     "Classes and functions to serve as the basis for other Gx packages")
+    (description
+     "This package provides a collection of functions and classes which serve as
+the foundation for our lab's suite of R packages, such as PharmacoGx and RadioGx.
+It was created to abstract shared functionality from other lab package releases
+to increase ease of maintainability and reduce code repetition in current and
+future Gx suite programs.  Major features include a @code{CoreSet} class, from
+which RadioSet and PharmacoSet are derived, along with get and set methods for
+each respective slot.  Additional functions related to fitting and plotting dose
+response curves, quantifying statistical correlation and calculating
+@acronym{AUC, area under the curve} or @acronym{SF, survival fraction} are
+included.")
+    (license license:gpl3+)))
+
 (define-public r-coverageview
   (package
     (name "r-coverageview")