diff mbox series

[bug#62728,1/2] gnu: openmw-openscenegraph: Fix build.

Message ID ea1e4bb1b159bd837ae0fd9c5dc93fd399278a72.1680980546.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series Update and fix the build of openmw-openscenegraph. | expand

Commit Message

Kaelyn Takata April 8, 2023, 7:27 p.m. UTC
* gnu/packages/graphics.scm (openmw-openscenegraph): Fix build.
---
 gnu/packages/graphics.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index bcc27cc3bf..09c7c4b6d2 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
 ;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1488,6 +1489,7 @@  (define-public openmw-openscenegraph
           (sha256
            (base32
             "05yhgq3qm5q277y32n5sf36vx5nv5qd3zlhz4csgd3a6190jrnia"))))
+       (outputs (list "out"))
        (arguments
         (substitute-keyword-arguments (package-arguments openscenegraph)
           ((#:configure-flags flags)
@@ -1503,7 +1505,9 @@  (define-public openmw-openscenegraph
                 "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
                 ;; The jpeg plugin requires conversion between integers and booleans
                 "-DCMAKE_CXX_FLAGS=-fpermissive")
-              #$flags))))))))
+              #$flags))
+          ((#:phases _)
+           #~%standard-phases)))))))

 (define-public povray
   (package