diff mbox series

[bug#62728,2/2] gnu: openmw-openscenegraph: Update to Nov 2022 commit.

Message ID 35d0c28292785c8b00b56fe04fb10400b4accbb5.1680980546.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series Update and fix the build of openmw-openscenegraph. | expand

Commit Message

Kaelyn Takata April 8, 2023, 7:27 p.m. UTC
* gnu/packages/graphics.scm (openmw-openscenegraph): Update to Nov 2022 commit.
[arguments]: Sync the plugin flags with the mentioned wiki page.
---
 gnu/packages/graphics.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 09c7c4b6d2..dff1ec86c9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1474,11 +1474,11 @@  (define-public gr-framework
 (define-public openmw-openscenegraph
   ;; OpenMW prefers its own fork of openscenegraph:
   ;; https://wiki.openmw.org/index.php?title=Development_Environment_Setup#OpenSceneGraph.
-  (let ((commit "36a962845a2c87a6671fd822157e0729d164e940"))
+  (let ((commit "69cfecebfb6dc703b42e8de39eed750a84a87489"))
     (hidden-package
      (package
        (inherit openscenegraph)
-       (version (git-version "3.6" "1" commit))
+       (version (git-version "3.6" "2" commit))
        (source
         (origin
           (method git-fetch)
@@ -1488,7 +1488,7 @@  (define-public openmw-openscenegraph
           (file-name (git-file-name (package-name openscenegraph) version))
           (sha256
            (base32
-            "05yhgq3qm5q277y32n5sf36vx5nv5qd3zlhz4csgd3a6190jrnia"))))
+            "1qayk2gklm8zvss90dcjfxv6717rvcmwmgmgyy1qzkli67a0zbw2"))))
        (outputs (list "out"))
        (arguments
         (substitute-keyword-arguments (package-arguments openscenegraph)
@@ -1497,14 +1497,14 @@  (define-public openmw-openscenegraph
            #~(append
               '("-DBUILD_OSG_PLUGINS_BY_DEFAULT=0"
                 "-DBUILD_OSG_PLUGIN_OSG=1"
+                "-DBUILD_OSG_PLUGIN_DAE=1"
                 "-DBUILD_OSG_PLUGIN_DDS=1"
                 "-DBUILD_OSG_PLUGIN_TGA=1"
                 "-DBUILD_OSG_PLUGIN_BMP=1"
                 "-DBUILD_OSG_PLUGIN_JPEG=1"
                 "-DBUILD_OSG_PLUGIN_PNG=1"
-                "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
-                ;; The jpeg plugin requires conversion between integers and booleans
-                "-DCMAKE_CXX_FLAGS=-fpermissive")
+                "-DBUILD_OSG_PLUGIN_FREETYPE=1"
+                "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0")
               #$flags))
           ((#:phases _)
            #~%standard-phases)))))))