diff mbox series

[bug#69669,gnome-team,v2,3/3] gnu: girara: Build with json-glib.

Message ID e7e764d914a28cb4f97156cd730af9b531e90cd5.1709974804.git.vivien@planete-kraus.eu
State New
Headers show
Series Update girara (better) | expand

Commit Message

Vivien Kraus March 9, 2024, 8:58 a.m. UTC
* gnu/packages/gtk.scm (girara) [propagated-inputs]: Add json-glib.

Change-Id: I5bfe5a516885153014fce1c6643ac5799f0100e1
---
 gnu/packages/gtk.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Maxim Cournoyer March 9, 2024, 5:55 p.m. UTC | #1
Hi Vivien,

Vivien Kraus <vivien@planete-kraus.eu> writes:

> * gnu/packages/gtk.scm (girara) [propagated-inputs]: Add json-glib.
>
> Change-Id: I5bfe5a516885153014fce1c6643ac5799f0100e1
> ---
>  gnu/packages/gtk.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 950476815f..3b834d748c 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -2168,7 +2168,7 @@ (define-public girara
>             `(,glib "bin")
>             xorg-server-for-tests))
>      ;; Listed in 'Requires.private' of 'girara.pc'.
> -    (propagated-inputs (list gtk+))
> +    (propagated-inputs (list gtk+ json-glib))

We'll want to revisit these propagated inputs after the core-updates
branch is merged, as Requires.private should only be needed when
producing static archives, not dynamic libraries (which pkgconf
interprets correctly).
Vivien Kraus March 9, 2024, 6:22 p.m. UTC | #2
Le samedi 09 mars 2024 à 12:55 -0500, Maxim Cournoyer a écrit :
> > -    (propagated-inputs (list gtk+))
> > +    (propagated-inputs (list gtk+ json-glib))
> 
> We'll want to revisit these propagated inputs after the core-updates
> branch is merged, as Requires.private should only be needed when
> producing static archives, not dynamic libraries (which pkgconf
> interprets correctly).

Should I do something in the mean time?
Maxim Cournoyer March 12, 2024, 3:47 a.m. UTC | #3
Hi,

Vivien Kraus <vivien@planete-kraus.eu> writes:

> Le samedi 09 mars 2024 à 12:55 -0500, Maxim Cournoyer a écrit :
>> > -    (propagated-inputs (list gtk+))
>> > +    (propagated-inputs (list gtk+ json-glib))
>> 
>> We'll want to revisit these propagated inputs after the core-updates
>> branch is merged, as Requires.private should only be needed when
>> producing static archives, not dynamic libraries (which pkgconf
>> interprets correctly).
>
> Should I do something in the mean time?

No, or if you want, you could leave a 'TODO: Remove propagated inputs
after core-updates is merged' or similar.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 950476815f..3b834d748c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2168,7 +2168,7 @@  (define-public girara
            `(,glib "bin")
            xorg-server-for-tests))
     ;; Listed in 'Requires.private' of 'girara.pc'.
-    (propagated-inputs (list gtk+))
+    (propagated-inputs (list gtk+ json-glib))
     (build-system meson-build-system)
     (home-page "https://pwmt.org/projects/girara/")
     (synopsis "Library for minimalistic gtk+3 user interfaces")