diff mbox series

[bug#69669,gnome-team,v2,1/3] gnu: girara: Update style.

Message ID 1a4864e2e1936be6053ca1330483a44da985730f.1709974804.git.vivien@planete-kraus.eu
State New
Headers show
Series Update girara (better) | expand

Commit Message

Vivien Kraus March 9, 2024, 8:54 a.m. UTC
* gnu/packages/gtk.scm (girara)[arguments]: Convert to list of G-Expressions.
[native-inputs]: Move after arguments.
[propagated-inputs]: Move after arguments.

Change-Id: I79a6f59f6ea671433f1a66a10cb79203f0b9bbae
---
 gnu/packages/gtk.scm | 47 +++++++++++++++++++++++---------------------
 1 file changed, 25 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a00ce71b81..033c5aee0f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2142,30 +2142,33 @@  (define-public girara
        (file-name (git-file-name name version))
        (sha256
         (base32 "0k93pi0lkf941vanvh1habm6n5wl1n63726j5kqxh34wdlv4mv4s"))))
-    (native-inputs `(("pkg-config" ,pkg-config)
-                     ("check" ,check)
-                     ("gettext" ,gettext-minimal)
-                     ("glib:bin" ,glib "bin")
-                     ("xorg-server" ,xorg-server-for-tests)))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'start-xserver
+            ;; Tests require a running X server.
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((xorg-server (assoc-ref inputs "xorg-server"))
+                    (display ":1"))
+                (setenv "DISPLAY" display)
+
+                ;; On busy machines, tests may take longer than
+                ;; the default of four seconds.
+                (setenv "CK_DEFAULT_TIMEOUT" "20")
+
+                ;; Don't fail due to missing '/etc/machine-id'.
+                (setenv "DBUS_FATAL_WARNINGS" "0")
+                (zero? (system (string-append xorg-server "/bin/Xvfb "
+                                              display " &")))))))))
+    (native-inputs
+     (list pkg-config
+           check
+           gettext-minimal
+           `(,glib "bin")
+           xorg-server-for-tests))
     ;; Listed in 'Requires.private' of 'girara.pc'.
     (propagated-inputs (list gtk+))
-    (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-before 'check 'start-xserver
-                    ;; Tests require a running X server.
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      (let ((xorg-server (assoc-ref inputs "xorg-server"))
-                            (display ":1"))
-                        (setenv "DISPLAY" display)
-
-                        ;; On busy machines, tests may take longer than
-                        ;; the default of four seconds.
-                        (setenv "CK_DEFAULT_TIMEOUT" "20")
-
-                        ;; Don't fail due to missing '/etc/machine-id'.
-                        (setenv "DBUS_FATAL_WARNINGS" "0")
-                        (zero? (system (string-append xorg-server "/bin/Xvfb "
-                                                      display " &")))))))))
     (build-system meson-build-system)
     (home-page "https://pwmt.org/projects/girara/")
     (synopsis "Library for minimalistic gtk+3 user interfaces")