diff mbox series

[bug#67131,2/7] gnu: Add python-pyglet.

Message ID e5e83231-03c4-f612-0180-2aa338a840f6@disroot.org
State New
Headers show
Series gnu: Add tuxemon. | expand

Commit Message

Adam Faiz Nov. 12, 2023, 5:09 p.m. UTC
From 945f787ec2972b18ecc1da56e1362f484a2a355e Mon Sep 17 00:00:00 2001
Message-ID: <945f787ec2972b18ecc1da56e1362f484a2a355e.1699806997.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1699806997.git.adam.faiz@disroot.org>
References: <cover.1699806997.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 12 Nov 2023 17:26:04 +0800
Subject: [PATCH 2/7] gnu: Add python-pyglet.

* gnu/packages/game-development.scm (python-pyglet): New variable.
---
 gnu/packages/game-development.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index abc7b35c25..1cf46464b9 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1395,6 +1395,30 @@  (define-public python-pygame
                    license:public-domain
                    license:lgpl2.1+))))
 
+(define-public python-pyglet
+  (package
+    (name "python-pyglet")
+    (version "2.0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyglet" version ".zip"))
+       (sha256
+        (base32 "1jdraqr7i3bz64m7yvhcnn3av5mnavn13fp5vzmmnz6n7cdynar4"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list unzip))
+    (arguments
+     ;; TypeError: don't know how to make test from:
+     ;; <pyglet._ModuleProxy object at 0x7ffff697df90>
+     (list #:tests? #f))
+    (home-page "http://pyglet.readthedocs.org/en/latest/")
+    (synopsis "Windowing and multimedia library")
+    (description "@code{pyglet} is a windowing and multimedia library for Python,
+intended for developing games and other visually rich applications.
+It supports windowing, user interface event handling, game controllers
+and joysticks, OpenGL graphics, loading images and videos, and playing sounds
+and music.")
+    (license license:bsd-3)))
 (define-public python-pygame-sdl2
   (let ((real-version "2.1.0")
         (renpy-version "8.1.0"))