diff mbox series

[bug#67131,5/7] gnu: Add python-pyscroll.

Message ID b41a8845-dc08-ed66-d946-d2bbcaa8f497@disroot.org
State New
Headers show
Series gnu: Add tuxemon. | expand

Commit Message

Adam Faiz Nov. 12, 2023, 5:12 p.m. UTC
From 678efa89885960e51109d8e0d4064d8657c9d4dc Mon Sep 17 00:00:00 2001
Message-ID: <678efa89885960e51109d8e0d4064d8657c9d4dc.1699806997.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1699806997.git.adam.faiz@disroot.org>
References: <cover.1699806997.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 12 Nov 2023 16:32:47 +0800
Subject: [PATCH 5/7] gnu: Add python-pyscroll.

* gnu/packages/game-development.scm (python-pyscroll): New variable.
---
 gnu/packages/game-development.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index c06fa7f916..a463335cd2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -506,6 +506,25 @@  (define-public python-neteria
     (description
      "This package is a game networking framework for Python.")
     (license license:gpl3+)))
+
+(define-public python-pyscroll
+  (package
+    (name "python-pyscroll")
+    (version "2.31")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pyscroll" version))
+              (sha256
+               (base32
+                "0w3c58mkkbsyvx9w9hwdizk20pbds800m7v9vg49ydw440dha0hr"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pygame))
+    (home-page "https://github.com/bitcraft/pyscroll")
+    (synopsis "Fast scrolling maps library for pygame")
+    (description "@code{pyscroll} is a simple and fast module
+for animated scrolling maps for your new or existing game.")
+    (license license:lgpl3+)))
+
 (define-public python-sge
   (package
     (name "python-sge")