diff mbox series

[bug#67131,4/7] gnu: Add python-pygame-menu.

Message ID 54a19a47-571d-cbcf-3dec-d9edf5295551@disroot.org
State New
Headers show
Series gnu: Add tuxemon. | expand

Commit Message

Adam Faiz Nov. 12, 2023, 5:11 p.m. UTC
From 436ff79c2d5304b69d8d38be30fa909971fa0604 Mon Sep 17 00:00:00 2001
Message-ID: <436ff79c2d5304b69d8d38be30fa909971fa0604.1699806997.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1699806997.git.adam.faiz@disroot.org>
References: <cover.1699806997.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 12 Nov 2023 23:29:34 +0800
Subject: [PATCH 4/7] gnu: Add python-pygame-menu.

* gnu/packages/game-development.scm (python-pygame-menu): New variable.
---
 gnu/packages/game-development.scm | 33 +++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 45d63b8cdf..c06fa7f916 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1422,6 +1422,39 @@  (define-public python-pyglet
 and joysticks, OpenGL graphics, loading images and videos, and playing sounds
 and music.")
     (license license:bsd-3)))
+
+(define-public python-pygame-menu
+  (package
+    (name "python-pygame-menu")
+    (version "4.4.3")
+    (source
+     ;; Tests not included in release.
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/ppizarror/pygame-menu")
+           (commit version)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0s7w8z931iw9rzsaq9810lbrgba9i2qhkryf0y011njc6bxhf6w4"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Some tests depend on having a mixer, and a few assertions fail
+     (list #:tests? #f))
+    (propagated-inputs (list python-pygame python-pyperclip
+                             python-typing-extensions))
+    (native-inputs (list python-nose2))
+    (home-page "https://pygame-menu.readthedocs.io")
+    (synopsis "Menu for pygame")
+    (description
+     "Pygame-menu is a python-pygame library for creating menus and GUIs.
+It supports several widgets, such as buttons, color inputs, clock objects,
+drop selectors, frames, images, labels, selectors, tables, text inputs,
+color switches, and many more, with multiple options to customize.")
+    (license license:expat)))
+
 (define-public python-pygame-sdl2
   (let ((real-version "2.1.0")
         (renpy-version "8.1.0"))