diff mbox series

[bug#70461,07/10] gnu: Add rust-ssh-key-0.6.6.

Message ID e15a07e6d66c60d354c0c39fce92627fb56fe5e4.1713472115.git.voroskoi@gmail.com
State New
Headers show
Series [bug#70461,01/10] gnu: rust-rayon: Update to 1.10.0. | expand

Commit Message

VÖRÖSKŐI András April 18, 2024, 8:28 p.m. UTC
* gnu/packages/crates-crypto.scm (rust-ssh-key-0.6): New variable.

Change-Id: I4ce4c4439cb28de053c21bccc0b214ec79ec8747
---
 gnu/packages/crates-crypto.scm | 44 ++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 1e52f72ca5..d0308c276c 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -6232,6 +6232,50 @@  (define-public rust-ssh-encoding-0.2
      "Pure Rust implementation of SSH data type decoders/encoders as described in
 RFC4251.")
     (license (list license:asl2.0 license:expat))))
+
+(define-public rust-ssh-key-0.6
+  (package
+    (name "rust-ssh-key")
+    (version "0.6.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ssh-key" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1z5sxiv5qk0ld9k3zhy0m1063d5zmq84vkzl0rjbn66gh1m3d6ya"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bcrypt-pbkdf" ,rust-bcrypt-pbkdf-0.10)
+                       ("rust-dsa" ,rust-dsa-0.6)
+                       ("rust-ed25519-dalek" ,rust-ed25519-dalek-2)
+                       ("rust-num-bigint-dig" ,rust-num-bigint-dig-0.8)
+                       ("rust-p256" ,rust-p256-0.13)
+                       ("rust-p384" ,rust-p384-0.13)
+                       ("rust-p521" ,rust-p521-0.13)
+                       ("rust-rand-core" ,rust-rand-core-0.6)
+                       ("rust-rsa" ,rust-rsa-0.9)
+                       ("rust-sec1" ,rust-sec1-0.7)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-sha1" ,rust-sha1-0.10)
+                       ("rust-sha2" ,rust-sha2-0.10)
+                       ("rust-signature" ,rust-signature-2)
+                       ("rust-ssh-cipher" ,rust-ssh-cipher-0.2)
+                       ("rust-ssh-encoding" ,rust-ssh-encoding-0.2)
+                       ("rust-subtle" ,rust-subtle-2)
+                       ("rust-zeroize" ,rust-zeroize-1))
+       #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.4)
+                                   ("rust-rand-chacha" ,rust-rand-chacha-0.3))))
+    (home-page "https://github.com/RustCrypto/SSH/tree/master/ssh-key")
+    (synopsis "Pure Rust implementation of SSH key file format")
+    (description
+     "Pure Rust implementation of SSH key file format decoders/encoders as described
+in RFC4251/RFC4253 and @code{OpenSSH} key formats, as well as @code{sshsig}
+signatures and certificates (including certificate validation and certificate
+authority support), with further support for the @code{authorized_keys} and
+@code{known_hosts} file formats.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-stream-cipher-0.4
   (package
     (name "rust-stream-cipher")