diff mbox series

[bug#70461,06/10] gnu: Add rust-ssh-cipher-0.2.0.

Message ID 75a8671a646cb5bb735a0249fe7c4dfd0dec490d.1713472115.git.voroskoi@gmail.com
State New
Headers show
Series [bug#70461,01/10] gnu: rust-rayon: Update to 1.10.0. | expand

Commit Message

VÖRÖSKŐI András April 18, 2024, 8:28 p.m. UTC
* gnu/packages/crates-crypto.scm (rust-ssh-cipher): New variable.

Change-Id: I3b25bb80bade833b4f289aeb24823fb38964c324
---
 gnu/packages/crates-crypto.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 898d9b8766..1e52f72ca5 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -6174,6 +6174,39 @@  (define-public rust-spki-0.4
         (base32 "0ckgkcg6db5y94dqhmyikgn8yrsah6pyf4j197hv1c51bp0s00aw"))))
     (arguments `(#:skip-build? #t #:cargo-inputs (("rust-der" ,rust-der-0.4))))))
 
+(define-public rust-ssh-cipher-0.2
+  (package
+    (name "rust-ssh-cipher")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ssh-cipher" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0kvq113x9fcy2jcxp00xk472zxm8d9zxxz2vyqx3rlzh88ki7b6a"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-aes" ,rust-aes-0.8)
+                       ("rust-aes-gcm" ,rust-aes-gcm-0.10)
+                       ("rust-cbc" ,rust-cbc-0.1)
+                       ("rust-chacha20" ,rust-chacha20-0.9)
+                       ("rust-cipher" ,rust-cipher-0.4)
+                       ("rust-ctr" ,rust-ctr-0.9)
+                       ("rust-des" ,rust-des-0.8)
+                       ("rust-poly1305" ,rust-poly1305-0.8)
+                       ("rust-ssh-encoding" ,rust-ssh-encoding-0.2)
+                       ("rust-subtle" ,rust-subtle-2))))
+    (home-page "https://github.com/RustCrypto/SSH/tree/master/ssh-cipher")
+    (synopsis
+     "Rust implementation of SSH symmetric encryption")
+    (description
+     "Pure Rust implementation of SSH symmetric encryption including support for the
+modern aes128, aes256 and chacha20-poly1305 algorithms as well as legacy support for older
+ciphers.  Built on the pure Rust cryptography implementations maintained by the
+@code{RustCrypto} organization.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-ssh-encoding-0.2
   (package
     (name "rust-ssh-encoding")