diff mbox series

[bug#70461,04/10] gnu: Add rust-p521-0.13.3.

Message ID 1b5eea1433e19d7b0d2ee86cbc8a61933e2bb3ee.1713472115.git.voroskoi@gmail.com
State New
Headers show
Series [bug#70461,01/10] gnu: rust-rayon: Update to 1.10.0. | expand

Commit Message

VÖRÖSKŐI András April 18, 2024, 8:28 p.m. UTC
* gnu/packages/crates-crypto.scm (rust-p521): New variable.

Change-Id: I7dfd717125f0bfb05456659a50afe6b4ba758717
---
 gnu/packages/crates-crypto.scm | 35 ++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 8f3b14a2a2..bf43b48e55 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -3355,6 +3355,41 @@  (define-public rust-p384-0.13
 signing/verification, and general purpose curve arithmetic support.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-p521-0.13
+  (package
+    (name "rust-p521")
+    (version "0.13.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "p521" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1cl5y2aypa1vxg181a0na3abndz1981pfdp2zkyml88z3wbf5j8g"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-base16ct" ,rust-base16ct-0.2)
+                       ("rust-ecdsa" ,rust-ecdsa-0.16)
+                       ("rust-elliptic-curve" ,rust-elliptic-curve-0.13)
+                       ("rust-hex-literal" ,rust-hex-literal-0.4)
+                       ("rust-primeorder" ,rust-primeorder-0.13)
+                       ("rust-rand-core" ,rust-rand-core-0.6)
+                       ("rust-serdect" ,rust-serdect-0.2)
+                       ("rust-sha2" ,rust-sha2-0.10))
+       #:cargo-development-inputs (("rust-blobby" ,rust-blobby-0.3)
+                                   ("rust-ecdsa" ,rust-ecdsa-0.16)
+                                   ("rust-hex-literal" ,rust-hex-literal-0.4)
+                                   ("rust-primeorder" ,rust-primeorder-0.13)
+                                   ("rust-proptest" ,rust-proptest-1)
+                                   ("rust-rand-core" ,rust-rand-core-0.6))))
+    (home-page
+     "https://github.com/RustCrypto/elliptic-curves/tree/master/p521")
+    (synopsis "Rust implementation of the NIST P-521")
+    (description
+     "Pure Rust implementation of the NIST P-521 (a.k.a.  secp521r1) elliptic curve as
+defined in SP 800-186")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-pbkdf2-0.12
   (package
     (name "rust-pbkdf2")