diff mbox series

[bug#66119,2/3] gnu: Add ocaml-ocb.

Message ID dfa2415028fbc9eaf1ba1a3c572b63ce9e50803f.1695203766.git.racin@free.fr
State New
Headers show
Series Some OCaml packages (needed for ocaml-toml) | expand

Commit Message

Matthieu Lemerre Sept. 20, 2023, 10:50 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-ocb): New variable.
---
 gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5caa2d6185..96ef416b30 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5834,6 +5834,29 @@  (define-public ocaml-ocb-stubblr
 OCaml projects that contain C stubs.")
    (license license:isc)))
 
+
+(define-public ocaml-ocb
+  (package
+    (name "ocaml-ocb")
+    (version "0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/OCamlPro/ocb")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1nk90jax91ld8qd36qi408mll8a7w1d60fa2qdsnff7cldwixc1d"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-odoc))
+    (home-page "https://ocamlpro.github.io/ocb/")
+    (synopsis "ocb (OCaml Badgen): SVG badge generation")
+    (description
+     "ocb (OCaml Badgen) is an OCaml library for SVG badge generation.
+There's also a command-line tool provided.")
+    (license license:isc)))
+
 (define-public ocaml-tsdl
   (package
     (name "ocaml-tsdl")