diff mbox series

[bug#66119,1/3] gnu: Add ocaml-iso8601.

Message ID 2bc75ea490306069a51706e822e49f8af87f00a8.1695203766.git.racin@free.fr
State New
Headers show
Series Some OCaml packages (needed for ocaml-toml) | expand

Commit Message

Matthieu Lemerre Sept. 20, 2023, 10:50 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-iso8601): New variable.
---
 gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ea9d3e3594..5caa2d6185 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2445,6 +2445,28 @@  (define-public ocaml-calendar
       ;; With linking exception.
       (license license:lgpl2.1+))))
 
+(define-public ocaml-iso8601
+  (package
+    (name "ocaml-iso8601")
+    (version "0.2.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ocaml-community/ISO8601.ml")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0nzadswspizi7s6sf67icn2xgc3w150x8vdg5nk1mjrm2s98n6d3"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-odoc))
+    (native-inputs (list ocaml-ounit))
+    (home-page "https://github.com/ocaml-community/ISO8601.ml/")
+    (synopsis "ISO 8601 and RFC 3999 date parsing for OCaml")
+    (description
+     "An OCaml library for parsing dates in ISO 8601 and RFC 3999 format.")
+    (license license:expat)))
+
 (define-public ocaml-cmdliner
   (package
     (name "ocaml-cmdliner")