diff mbox series

[bug#65479,core-updates,61/61] gnu: Remove unneeded libxml2 from native-inputs. (gtk-doc)

Message ID df19c8070d67389fb19c44871d8b253bedd13f47.1692830150.git.mirai@makinata.eu
State New
Headers show
Series The Draining of the XML & DocBook Swamp. | expand

Commit Message

Bruno Victal Aug. 23, 2023, 10:35 p.m. UTC
The gtk-doc wrapped binaries use XML_CATALOG_FILES to perform XML catalog
lookup and come with docbook-xsl within the variable which fixes the
docbook-xsl stylesheet lookup related failures with these packages.
This makes it unnecessary to include libxml2 as the cause of error was usually
with the gtk-doc binaries.

* gnu/packages/gnome.scm (gupnp-igd, dee, zeitgeist, libnma)[native-inputs]:
Remove libxml2.
* gnu/packages/rpm.scm (libmodulemd)[native-inputs]: Ditto.
* gnu/packages/security-token.scm (libu2f-host)[native-inputs]: Ditto.
---
 gnu/packages/gnome.scm          | 4 ----
 gnu/packages/rpm.scm            | 3 +--
 gnu/packages/security-token.scm | 5 ++---
 3 files changed, 3 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f5b975f514..31be773416 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -281,7 +281,6 @@  (define-public gupnp-igd
            gobject-introspection
            gsettings-desktop-schemas
            gtk-doc/stable
-           libxml2                      ;for XML_CATALOG_FILES
            pkg-config))
     (propagated-inputs
      ;; These libraries are required by the .pc file.
@@ -663,7 +662,6 @@  (define-public dee
            gtk-doc/stable
            ;; Would only be required by configure flag "--enable-extended-tests".
            ;;gtx
-           libxml2                      ;for XML_CATALOG_FILES
            pkg-config
            python-pygobject
            python-wrapper
@@ -725,7 +723,6 @@  (define-public zeitgeist
            gobject-introspection
            gtk-doc/stable
            libtool
-           libxml2                      ;for XML_CATALOG_FILES
            pkg-config
            vala
            xorg-server-for-tests))
@@ -1772,7 +1769,6 @@  (define-public libnma
            `(,glib "bin")
            gtk-doc/stable
            gobject-introspection
-           libxml2                      ;for XML_CATALOG_FILES
            pkg-config
            vala))
     (inputs
diff --git a/gnu/packages/rpm.scm b/gnu/packages/rpm.scm
index b7802e3ecd..3df5756ef4 100644
--- a/gnu/packages/rpm.scm
+++ b/gnu/packages/rpm.scm
@@ -116,9 +116,8 @@  (define-public libmodulemd
            `(,glib "bin")
            `(,glib-with-documentation "doc")
            gobject-introspection        ;for g-ir-scanner
-           gtk-doc
+           gtk-doc/stable
            help2man
-           libxml2                      ;for XML_CATALOG_FILES
            pkg-config
            python))                     ;for 'site-packages' call
     (inputs
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 6d7f5c9ab2..c6d7a1ea1f 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -593,10 +593,9 @@  (define-public libu2f-host
      (list help2man
            gengetopt
            pkg-config
-           gtk-doc
+           gtk-doc/stable
            docbook-xml-4.3
-           eudev
-           libxml2))                    ;for XML_CATALOG_FILES
+           eudev))
     (home-page "https://developers.yubico.com/libu2f-host/")
     ;; TRANSLATORS: The U2F protocol has a "server side" and a "host side".
     (synopsis "U2F host-side C library and tool")