diff mbox series

[bug#65479,core-updates,16/61] gnu: dblatex: Split documentation.

Message ID 986bad59cde03edca033dff2af2fe6533a6a7540.1692830149.git.mirai@makinata.eu
State New
Headers show
Series The Draining of the XML & DocBook Swamp. | expand

Commit Message

Bruno Victal Aug. 23, 2023, 10:35 p.m. UTC
* gnu/packages/docbook.scm (dblatex)[arguments]<#:phases>: Add split-outputs.
[outputs]: Add doc.
---
 gnu/packages/docbook.scm | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Maxim Cournoyer Oct. 6, 2023, 12:01 a.m. UTC | #1
Bruno Victal <mirai@makinata.eu> writes:

> * gnu/packages/docbook.scm (dblatex)[arguments]<#:phases>: Add split-outputs.
> [outputs]: Add doc.
> ---
>  gnu/packages/docbook.scm | 7 +++++++
>  1 file changed, 7 insertions(+)
>
> diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
> index 0ecaefe253..91b3eeeccb 100644
> --- a/gnu/packages/docbook.scm
> +++ b/gnu/packages/docbook.scm
> @@ -706,6 +706,12 @@ (define-public dblatex
>        #:tests? #f                       ;no test suite
>        #:phases
>        #~(modify-phases %standard-phases
> +          (add-after 'install 'split-outputs

s/split-outputs/move-doc/

> +            (lambda _
> +              (let ((old (string-append #$output "/share/doc"))
> +                    (new (string-append #$output:doc "/share/doc")))
> +                (mkdir-p (dirname new))
> +                (rename-file old new))))
>            (add-after 'wrap 'set-path
>              (lambda* (#:key inputs #:allow-other-keys)
>                (let ((path (map (lambda (x)
> @@ -742,6 +748,7 @@ (define-public dblatex
>             inkscape/stable              ;for svg conversion
>             docbook-xml
>             libxslt))                    ;for xsltproc
> +    (outputs '("out" "doc"))

nitpick: Move above build-systems field.
diff mbox series

Patch

diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 0ecaefe253..91b3eeeccb 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -706,6 +706,12 @@  (define-public dblatex
       #:tests? #f                       ;no test suite
       #:phases
       #~(modify-phases %standard-phases
+          (add-after 'install 'split-outputs
+            (lambda _
+              (let ((old (string-append #$output "/share/doc"))
+                    (new (string-append #$output:doc "/share/doc")))
+                (mkdir-p (dirname new))
+                (rename-file old new))))
           (add-after 'wrap 'set-path
             (lambda* (#:key inputs #:allow-other-keys)
               (let ((path (map (lambda (x)
@@ -742,6 +748,7 @@  (define-public dblatex
            inkscape/stable              ;for svg conversion
            docbook-xml
            libxslt))                    ;for xsltproc
+    (outputs '("out" "doc"))
     ;; lib/dbtexmf/xslt/4xslt.py shows that this package
     ;; makes use of XML_CATALOG_FILES.
     ;; It also invokes xsltproc, that already has it