mbox series

[bug#65479,core-updates,00/61] The Draining of the XML & DocBook Swamp.

Message ID cover.1692828533.git.mirai@makinata.eu
Headers show
Series The Draining of the XML & DocBook Swamp. | expand

Message

Bruno Victal Aug. 23, 2023, 10:33 p.m. UTC
This is a follow-up for <https://issues.guix.gnu.org/63081> and brings
several QoL improvements for handling XML/XSL dependencies in packages.

Notable changes:
* Rebased against core-updates.
* Fixes profile conflicts for docbook-xml packages by using versioned paths.
  This is required for multiple docbook-xml packages to coexist within the
  same profile, a must when authoring or validating DocBook documents.
* Stores the schema files correctly rather than lumping it all within .../dtd/.
* New search-paths: $XML_CATALOG_FILES and $SGML_CATALOG_FILES.
  * Reduces direct dependencies on libxml2.
* Integrates some patches from Debian for docbook2x and docbook-utils.
* Fixes dblatex not finding the necessary binaries and texlive extensions.
* Several packages are now able to build their manpage and info docs.

Notes:
* Integrates the first patch from <https://issues.guix.gnu.org/63854>.

Bruno Victal (61):
  gnu: docbook-xml: Fix installation paths.
  gnu: Add docbook-xml-5.0.1.
  gnu: docbook-xml-5.1: Fix URIs in catalog.xml.
  gnu: docbook-xsl: Add compatibility entry.
  gnu: docbook-xsl: Add rewrite entries for http.
  gnu: docbook: Remove leftovers.
  gnu: docbook-utils: Import patches from debian.
  gnu: docbook2x: Import patches from debian.
  gnu: docbook2x: Fix sgml2xml-isoent and add test dependencies.
  gnu: docbook2x: Split documentation.
  gnu: libxml2: Rewrite using G-Expressions.
  search-paths: Add $XML_CATALOG_FILES and $SGML_CATALOG_FILES.
  gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.
  gnu: libxslt: Set search-paths for XML and SGML catalogs.
  gnu: dblatex: Add libxslt native-search-paths to its own.
  gnu: dblatex: Split documentation.
  gnu: Add docbook-mathml-1.0.
  gnu: dblatex: Fix missing texlive binaries.
  gnu: lilypond: Use dblatex/stable.
  gnu: docbook2x: Set search-paths for XML and SGML catalogs.
  gnu: xmlto: Rewrite with G-Expressions.
  gnu: xmlto: Add libxslt native-search-paths to its own.
  gnu: gtk-doc: Add libxslt native-search-paths to its own.
  gnu: docbook2x: Drop docbook-xml workarounds.
  gnu: secilc: Drop xmlto workaround.
  gnu: xdg-utils: Drop docbook workarounds.
  gnu: xdg-user-dirs: Drop docbook workaround.
  gnu: udisks: Rewrite using G-Expressions.
  gnu: udisks: Drop docbook workaround.
  gnu: colord-gtk: Build documentation.
  gnu: criu: Drop xmlto workaround.
  gnu: gtk: Drop docbook workaround.
  gnu: git-crypt: Remove docbook workarounds.
  gnu: gnome-session: Build documentation.
  gnu: metapixel: Drop docbook workaround.
  gnu: metapixel: Rewrite with G-Expressions.
  gnu: libxkbcommon: Add doc output.
  gnu: libxkbcommon: Faux propagate libxml2.
  gnu: gnome-session: Remove libxml2.
  gnu: sssd: Drop xmllint workaround.
  gnu: tdb: Build manpages.
  gnu: drumstick: Drop docbook workaround.
  gnu: vmpk: Drop docbook workaround.
  gnu: iputils: Drop docbook workarounds.
  gnu: iputils: Restyle.
  gnu: libnotify: Drop docbook workarounds.
  gnu: libnotify: Split documentation.
  gnu: alsa-utils: Build manpages.
  gnu: alsa-utils: Rewrite with G-Expressions.
  gnu: tunctl: Update comment.
  gnu: gdcm: Build manpages.
  gnu: git: Drop docbook workarounds.
  gnu: gtk-doc: Rewrite with G-Expressions.
  gnu: gtk-doc: Wrap XML_CATALOG_FILES.
  gnu: gtk-doc: Remove leftovers.
  gnu: libstdc++-doc: Rewrite with G-Expressions.
  gnu: libstdc++-doc: Build libstdc++ info documentation.
  gnu: perf: Remove libxml2.
  gnu: Remove unneeded libxml2 from native-inputs. (libxslt)
  gnu: Remove unneeded libxml2 from native-inputs. (xmlto)
  gnu: Remove unneeded libxml2 from native-inputs. (gtk-doc)

 doc/guix.texi                                 |  24 +-
 gnu/local.mk                                  |  19 +-
 gnu/packages/benchmark.scm                    |   1 -
 gnu/packages/bioinformatics.scm               |   6 +-
 gnu/packages/cluster.scm                      |   1 -
 gnu/packages/databases.scm                    |   6 +-
 gnu/packages/docbook.scm                      | 684 ++++++++++++------
 gnu/packages/freedesktop.scm                  | 194 ++---
 gnu/packages/gcc.scm                          |  59 +-
 gnu/packages/glib.scm                         |   1 -
 gnu/packages/gnome.scm                        |  37 +-
 gnu/packages/gtk.scm                          |  53 +-
 gnu/packages/image-processing.scm             |  51 +-
 gnu/packages/linux.scm                        |  58 +-
 gnu/packages/moreutils.scm                    |   2 +-
 gnu/packages/music.scm                        |  30 +-
 gnu/packages/networking.scm                   |  63 +-
 gnu/packages/ocr.scm                          |   1 -
 .../patches/dblatex-inkscape-1.0.patch        |  39 +
 .../docbook-utils-documentation-edits.patch   | 100 +++
 .../docbook-utils-escape-characters.patch     |  34 +
 .../docbook-utils-remove-jade-sp.patch        | 215 ++++++
 ...book-utils-respect-refentry-for-name.patch |  34 +
 .../docbook-utils-source-date-epoch.patch     |  29 +
 .../docbook-utils-use-date-element.patch      |  61 ++
 ...ocbook-xsl-nonrecursive-string-subst.patch |  40 -
 .../patches/docbook-xsl-support-old-url.patch |  17 -
 .../patches/docbook2x-filename-handling.patch |  42 ++
 .../patches/docbook2x-manpage-typo.patch      |  24 +
 .../docbook2x-preprocessor-declaration.patch  |  89 +++
 .../docbook2x-static-datadir-evaluation.patch |  19 +
 ...gcc-13.2.0-libstdc++-docbook-xsl-uri.patch |  50 ++
 ...cc-13.2.0-libstdc++-info-install-fix.patch |  70 ++
 .../gcc-5.5.0-libstdc++-xmlcatalog.patch      | 402 ++++++++++
 .../patches/libsepol-versioned-docbook.patch  |  56 ++
 gnu/packages/perl.scm                         |   7 +-
 gnu/packages/polkit.scm                       |   1 -
 gnu/packages/rpm.scm                          |   3 +-
 gnu/packages/samba.scm                        |   3 +-
 gnu/packages/security-token.scm               |   5 +-
 gnu/packages/selinux.scm                      |  13 +-
 gnu/packages/sssd.scm                         |   8 +-
 gnu/packages/terminals.scm                    |   1 -
 gnu/packages/version-control.scm              |  53 +-
 gnu/packages/virtualization.scm               |  10 -
 gnu/packages/wm.scm                           |   3 +-
 gnu/packages/xdisorg.scm                      |  32 +-
 gnu/packages/xml.scm                          |  83 +--
 guix/search-paths.scm                         |  25 +
 49 files changed, 2084 insertions(+), 774 deletions(-)
 create mode 100644 gnu/packages/patches/dblatex-inkscape-1.0.patch
 create mode 100644 gnu/packages/patches/docbook-utils-documentation-edits.patch
 create mode 100644 gnu/packages/patches/docbook-utils-escape-characters.patch
 create mode 100644 gnu/packages/patches/docbook-utils-remove-jade-sp.patch
 create mode 100644 gnu/packages/patches/docbook-utils-respect-refentry-for-name.patch
 create mode 100644 gnu/packages/patches/docbook-utils-source-date-epoch.patch
 create mode 100644 gnu/packages/patches/docbook-utils-use-date-element.patch
 delete mode 100644 gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch
 delete mode 100644 gnu/packages/patches/docbook-xsl-support-old-url.patch
 create mode 100644 gnu/packages/patches/docbook2x-filename-handling.patch
 create mode 100644 gnu/packages/patches/docbook2x-manpage-typo.patch
 create mode 100644 gnu/packages/patches/docbook2x-preprocessor-declaration.patch
 create mode 100644 gnu/packages/patches/docbook2x-static-datadir-evaluation.patch
 create mode 100644 gnu/packages/patches/gcc-13.2.0-libstdc++-docbook-xsl-uri.patch
 create mode 100644 gnu/packages/patches/gcc-13.2.0-libstdc++-info-install-fix.patch
 create mode 100644 gnu/packages/patches/gcc-5.5.0-libstdc++-xmlcatalog.patch
 create mode 100644 gnu/packages/patches/libsepol-versioned-docbook.patch


base-commit: c365cc69881f3aec633b88ba22c7fe8faec3597e