diff mbox series

[bug#69238,07/10] gnu: go-github-com-songmu-gitconfig: Move to golang-xyz.

Message ID de0b5d48b993a44a33fdb46f596b5da019ec163c.1708155311.git.sharlatanus@gmail.com
State New
Headers show
Series Fix failed builds from evaluation 1123386. | expand

Commit Message

Sharlatan Hellseher Feb. 18, 2024, 6:39 p.m. UTC
* gnu/packages/golang.scm (go-github-com-songmu-gitconfig): Move from
here ...
* gnu/packages/golang-xyz.scm: ... to here.

* gnu/packages/version-control.scm: Add (gnu packages golang-xyx)
module.

Change-Id: Ibab2595d981d46096501bb8ab495e899d2aacf7d
---
 gnu/packages/golang-xyz.scm      | 28 ++++++++++++++++++++++++++++
 gnu/packages/golang.scm          | 26 --------------------------
 gnu/packages/version-control.scm |  1 +
 3 files changed, 29 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c64200d365..a6031a8354 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
 ;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -1019,6 +1020,33 @@  (define-public go-github-com-songgao-water
 Use waterutil with it to work with TUN/TAP packets/frames.")
     (license license:bsd-3)))
 
+(define-public go-github-com-songmu-gitconfig
+  (package
+    (name "go-github-com-songmu-gitconfig")
+    (version "0.1.0")
+    (home-page "https://github.com/songmu/gitconfig")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1y01h496a7pfj1g2bclls5b0nl3vnj7nz610jj1dzq9kxrwxk7fk"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/Songmu/gitconfig"
+       ;; Package's tests appear to be hardcoded to the author's gitconfig
+       ;; and require network access.
+       #:tests? #f))
+    (propagated-inputs
+     (list go-github-com-goccy-yaml))
+    (synopsis "Go library to get configuration values from gitconfig")
+    (description
+     "@{gitconfig} is a package to get configuration values from gitconfig.")
+    (license license:expat)))
+
 (define-public go-github-com-stathat-go
   (let ((commit "74669b9f388d9d788c97399a0824adbfee78400e")
         (revision "0"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d877135282..5ba69b480d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8930,32 +8930,6 @@  (define-public go-github-com-tekwizely-go-parsing
 parsers, and related tools.")
       (license license:expat))))
 
-(define-public go-github-com-songmu-gitconfig
-  (package
-    (name "go-github-com-songmu-gitconfig")
-    (version "0.1.0")
-    (home-page "https://github.com/songmu/gitconfig")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url home-page)
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1y01h496a7pfj1g2bclls5b0nl3vnj7nz610jj1dzq9kxrwxk7fk"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/Songmu/gitconfig"
-       ;; Package's tests appear to be hardcoded to the author's gitconfig
-       ;; and require network access.
-       #:tests? #f))
-    (propagated-inputs
-     (list go-github-com-goccy-yaml))
-    (synopsis "Go library to get configuration values from gitconfig")
-    (description "@{gitconfig} is a package to get configuration values from gitconfig.")
-    (license license:expat)))
-
 (define-public go-github-com-akosmarton-papipes
   (let ((commit "3c63b4919c769c9c2b2d07e69a98abb0eb47fe64")
         (revision "0"))
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 51754245d3..d7750ed269 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -110,6 +110,7 @@  (define-module (gnu packages version-control)
   #:use-module (gnu packages golang-check)
   #:use-module (gnu packages golang-crypto)
   #:use-module (gnu packages golang-web)
+  #:use-module (gnu packages golang-xyz)
   #:use-module (gnu packages groff)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages guile-xyz)