diff mbox series

[bug#66921,5/5] gnu: Add r-screpertoire.

Message ID d9923f797e2b8e0a387633afdab92f319c39ba2b.1699029004.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#66921,1/5] gnu: Add r-evd. | expand

Commit Message

Mădălin Ionel Patrașcu Nov. 3, 2023, 4:30 p.m. UTC
* gnu/packages/bioconductor.scm (r-screpertoire): New variable.

Change-Id: Iaa876f787d5e39ca2888bf2082da3d7839224e15
---
 gnu/packages/bioconductor.scm | 43 +++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b683868df5..8306b703de 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10014,6 +10014,49 @@  (define-public r-scmap
 different experiment.")
     (license license:gpl3)))
 
+(define-public r-screpertoire
+  (package
+    (name "r-screpertoire")
+    (version "1.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "scRepertoire" version))
+       (sha256
+        (base32 "1wgs8dv5zl82iciy86w5ws1gq8v2piklcifbw7gmbw60kijyr2l1"))))
+    (properties `((upstream-name . "scRepertoire")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-doparallel
+           r-dplyr
+           r-ggalluvial
+           r-ggplot2
+           r-ggraph
+           r-igraph
+           r-plyr
+           r-powertcr
+           r-reshape2
+           r-rlang
+           r-seuratobject
+           r-singlecellexperiment
+           r-stringdist
+           r-stringr
+           r-summarizedexperiment
+           r-tidygraph
+           r-vegan))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/scRepertoire")
+    (synopsis "Toolkit for single-cell immune receptor profiling")
+    (description
+     "The scRepertoire package was built to process data derived from the 10x
+Genomics Chromium Immune Profiling for both @acronym{TCR, T-cell receptor} and
+@acronym{Ig, immunoglobulin} enrichment workflows and subsequently interacts with
+the popular Seurat and SingleCellExperiment R packages.  It also allows for
+general analysis of single-cell clonotype information without the use of
+expression information.  The package functions as a wrapper for Startrac and
+powerTCR R packages.")
+    (license license:gpl2)))
+
 (define-public r-scry
   (package
     (name "r-scry")