diff mbox series

[bug#66921,4/5] gnu: Add r-powertcr.

Message ID a0a6740a9dd6042f0184388005eebd85b7e40172.1699029004.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#66921,1/5] gnu: Add r-evd. | expand

Commit Message

Mădălin Ionel Patrașcu Nov. 3, 2023, 4:30 p.m. UTC
* gnu/packages/bioconductor.scm (r-powertcr): New variable.

Change-Id: I75fc30a7021d6199b768318da3afcfeaaafcf027
---
 gnu/packages/bioconductor.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d79236ea26..b683868df5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9236,6 +9236,37 @@  (define-public r-piano
 set analyses.")
     (license license:gpl2+)))
 
+(define-public r-powertcr
+  (package
+    (name "r-powertcr")
+    (version "1.22.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "powerTCR" version))
+       (sha256
+        (base32 "06fmphdq95pjbbvm8m8h1wajbp3vhl0zj7ddbzks9fy7ankp1n3i"))))
+    (properties `((upstream-name . "powerTCR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-cubature
+           r-doparallel
+           r-evmix
+           r-foreach
+           r-magrittr
+           r-purrr
+           r-truncdist
+           r-vegan
+           r-vgam))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/powerTCR")
+    (synopsis "Model-based comparative analysis of the TCR repertoire")
+    (description
+     "This package provides a model for the clone size distribution of the
+@acronym{TCR, T-cell receptor} repertoire.  Further, it permits comparative
+analysis of TCR repertoire libraries based on theoretical model fits.")
+    (license license:artistic2.0)))
+
 ;; This is a CRAN package, but it depends on a Bioconductor package:
 ;; r-aroma-light, r-dnacopy..
 (define-public r-pscbs