diff mbox series

[bug#66921,3/5] gnu: Add r-evmix.

Message ID 1decef87f8fc7d344825970f0b5f51ad0e820d71.1699029004.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#66921,1/5] gnu: Add r-evd. | expand

Commit Message

Mădălin Ionel Patrașcu Nov. 3, 2023, 4:30 p.m. UTC
* gnu/packages/cran.scm (r-evmix): New variable.

Change-Id: I93152dee218e9cef85dd66e17231f1728f0ffb52
---
 gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d7334963ec..bc3158eea6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7134,6 +7134,35 @@  (define-public r-evd
 threshold models.")
     (license license:gpl3)))
 
+(define-public r-evmix
+  (package
+    (name "r-evmix")
+    (version "2.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "evmix" version))
+       (sha256
+        (base32 "02rabc9snci00s1x7h0svfr66lmw1wjcdg0149wc52mnccsdaivf"))))
+    (properties `((upstream-name . "evmix")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-gsl
+           r-mass
+           r-sparsem))
+    (home-page "http://www.math.canterbury.ac.nz/~c.scarrott/evmix.shtml")
+    (synopsis
+     "Extreme value threshold estimation and uncertainty quantification")
+    (description
+     "This package provides the usual distribution functions, maximum likelihood
+inference and model diagnostics for univariate stationary extreme value mixture
+models.  Also, there are provided kernel density estimation including various
+boundary corrected kernel density estimation methods and a wide choice of kernels,
+with cross-validation likelihood based bandwidth estimator.  Reasonable
+consistency with the base functions in the evd package is provided, so that users
+can safely interchange most code.")
+    (license license:gpl3)))
+
 (define-public r-excelr
   (package
     (name "r-excelr")