diff mbox series

[bug#56740,6/6] gnu: Add python-types-orjson.

Message ID d789ca25f4fda919c5071912cd1b22c3b409f56f.1658669553.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Some python modules | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 24, 2022, 2:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-types-orjson): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 77469f1edc..0f26ee718d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30284,3 +30284,21 @@  sliceables (1 indexed, both start and end index are inclusive).  Helps to
 slice file content line by line or column by column or a combination of
 both.")
     (license license:bsd-3)))
+
+(define-public python-types-orjson
+  (package
+    (name "python-types-orjson")
+    (version "3.6.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "types-orjson" version))
+              (sha256
+               (base32
+                "0f66lf2qrl9d4vad42db3dmnzv89h4rr05r5zxx5qcl6kb3zr6ng"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/python/typeshed")
+    (synopsis "Typing stubs for orjson")
+    (description "This is a PEP 561 type stub package for the @code{orjson}
+package.  It can be used by type-checking tools like mypy, PyCharm, pytype
+etc. to check code that uses @code{orjson}.")
+    (license license:asl2.0)))