diff mbox series

[bug#56740,3/6] gnu: Add python-cyclic.

Message ID 52198f6153971dd379630f65b85ae8933131eaf1.1658669552.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Some python modules | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 24, 2022, 2:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-cyclic): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4cb7f6a801..a00df8c716 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30199,3 +30199,26 @@  GeoPackage Binary")
 GeoJSON to WKT/WKB (Well-Known Text/Binary) or GeoPackage Binary, and vice
 versa.  Extended WKB/WKT are also supported.")
     (license license:asl2.0)))
+
+(define-public python-cyclic
+  (package
+    (name "python-cyclic")
+    (version "1.0.0")
+    (source (origin
+              ;; Use git, as there are some test files missing from the PyPI
+              ;; release, see https://github.com/neurobin/cyclic/issues/1
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/neurobin/cyclic")
+                    ;; Release is not tagged on github, see
+                    ;; https://github.com/neurobin/cyclic/issues/2
+                    (commit "bf616c47ea49a43500ea55a1e6f4890323be0679")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0r8zzjdv70fpxssxps62rlgpii8fr9gh8gykdygqn6mkdnfjwgjc"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/neurobin/cyclic")
+    (synopsis "Handle cyclic relations")
+    (description "This package handles cyclic relations compared by value.")
+    (license license:bsd-3)))