diff mbox series

[bug#56740,1/6] gnu: Add python-mkdocs-markdownextradata-plugin.

Message ID 92280947d801c960ec13554e35b5ec057ef8a8df.1658669552.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Some python modules | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 24, 2022, 2:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-mkdocs-markdownextradata-plugin): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ee733f85af..4cb7f6a801 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -690,6 +690,32 @@  project documentation.  Documentation source files are written in Markdown, and
 configured with a single YAML configuration file.")
     (license license:bsd-3)))
 
+(define-public python-mkdocs-markdownextradata-plugin
+  (package
+    (name "python-mkdocs-markdownextradata-plugin")
+    (version "0.2.5")
+    (source (origin
+       ;; Use git, as there are some test files missing from the PyPI release,
+       ;; see https://github.com/rosscdh/mkdocs-markdownextradata-plugin/issues/41.
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rosscdh/mkdocs-markdownextradata-plugin")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1a3868s9m7pzyfncpjbjsa9vw5nihssl2v47pxj7h6qa67kvlk3g"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest))
+    (propagated-inputs (list python-mkdocs python-pyyaml))
+    (home-page "https://github.com/rosscdh/mkdocs-markdownextradata-plugin/")
+    (synopsis "Inject mkdocs.yml extra variables into the MkDocs markdown
+template")
+    (description
+     "This package provides a MkDocs plugin that injects the mkdocs.yml extra
+variables into the markdown template")
+    (license license:expat)))
+
 (define-public python-pymdown-extensions
   (package
     (name "python-pymdown-extensions")