diff mbox series

[bug#69628,qt-team,v4,19/24] gnu: python-{shiboken, pyside}-6: Update to 6.6.2.

Message ID d3564622000730b3264bf82f353555cddf75398d.1710320156.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series qt: Update to 6.6.2. | expand

Commit Message

Z572 March 13, 2024, 8:58 a.m. UTC
* gnu/packages/qt.scm (python-shiboken-6, python-pyside-6): Update to 6.6.2.
(python-shiboken-6)[properties]: Set upstream-name.
(python-pyside-6)[arguments]<#:phases>: Add 'set-rpath phase.

Change-Id: I098481f860c3bc97a629cca719305b2d00c3eace
---
 gnu/packages/qt.scm | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 053f589987..6b58fe2211 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4498,7 +4498,7 @@  (define-public python-shiboken-6
   (package
     (inherit python-shiboken-2)
     (name "python-shiboken-6")
-    (version "6.5.2")
+    (version "6.6.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://qt/QtForPython/pyside6/PySide6-"
@@ -4506,7 +4506,7 @@  (define-public python-shiboken-6
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1a0v9mjlcjbffm4lf5cfg45hvqai9654p95ygj5cjhfd9z8z3nwh"))))
+                "1w690jpxrski7c71gx05q5fvl2117lnjj5ih8iwckx3s9mlhnqhl"))))
     (build-system cmake-build-system)
     (inputs
      (modify-inputs (package-inputs python-shiboken-2)
@@ -4526,7 +4526,8 @@  (define-public python-shiboken-6
            "-DCMAKE_SKIP_RPATH=TRUE"
            (string-append "-DCMAKE_MODULE_LINKER_FLAGS=-Wl,-rpath="
                           #$output "/lib")
-           #$flags))))))
+           #$flags))))
+    (properties `((upstream-name . "pyside-setup")))))
 
 (define-public python-pyside-2
   (package
@@ -4668,6 +4669,11 @@  (define-public python-pyside-6
       #~(modify-phases %standard-phases
           (add-after 'unpack 'go-to-source-dir
             (lambda _ (chdir "sources/pyside6")))
+          (add-after 'go-to-source-dir 'set-rpath
+            (lambda _
+              (substitute* "CMakeLists.txt"
+                (("CMAKE_INSTALL_RPATH")
+                 (string-append "CMAKE_INSTALL_RPATH " #$output "/lib")))))
           (add-after 'go-to-source-dir 'fix-qt-module-detection
             (lambda _
               (substitute* "cmake/PySideHelpers.cmake"