diff mbox series

[bug#69628,qt-team,v4,21/24] gnu: Add qtsensors.

Message ID 1a076458b935dfec6b04153db06a3b8a407b7c52.1710320157.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series qt: Update to 6.6.2. | expand

Commit Message

Z572 March 13, 2024, 9:01 a.m. UTC
* gnu/packages/qt.scm (qtsensors): New variable.

Change-Id: I5d5bf3902f3340d6e73dc8889e27d4e5bf28b058
---
 gnu/packages/qt.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 5a24b7da25..f5c63800c9 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1664,6 +1664,25 @@  (define-public qtwebsockets
     (home-page (package-home-page qtbase))
     (license (package-license qtbase))))
 
+(define-public qtsensors
+  (package
+    (inherit qtsvg)
+    (name "qtsensors")
+    (version "6.6.2")
+    (source (origin
+              (method url-fetch)
+              (uri (qt-url name version))
+              (sha256
+               (base32
+                "0a3w50bfnmxndyxnn9lsy1wxffhm2am0yjxqx3vx0gfjwv79yvsa"))))
+    (native-inputs
+     (list qtdeclarative))
+    (inputs (list qtbase))
+    (synopsis "Qt Sensors module")
+    (description "The Qt Sensors API provides access to sensor hardware via QML
+and C++ interfaces.  The Qt Sensors API also provides a motion gesture
+recognition API for devices.")))
+
 (define-public qtsensors-5
   (package
     (inherit qtsvg-5)