diff mbox series

[bug#69628,qt-team,v4,08/24] gnu: qtmultimedia: Update to 6.6.2.

Message ID 6671f28e215aad61998098f73e50eb46544bb4a4.1710320156.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series qt: Update to 6.6.2. | expand

Commit Message

Z572 March 13, 2024, 8:58 a.m. UTC
* gnu/packages/qt.scm (qtmultimedia): Update to 6.6.2.
[arguments]<#:phases>: Adjust 'disable-integration-tests phase.

Change-Id: I8dd6e4767b40436199e4d45a0b75c4bd3136b386
---
 gnu/packages/qt.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ffd1064223..ce038082e8 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1773,13 +1773,13 @@  (define-public qtshadertools
 (define-public qtmultimedia
   (package
     (name "qtmultimedia")
-    (version "6.5.2")
+    (version "6.6.2")
     (source (origin
               (method url-fetch)
               (uri (qt-url name version))
               (sha256
                (base32
-                "0xc9k4mlncscxqbp8q46yjd89k4jb8j0ggbi5ad874lycym013wl"))
+                "1v0430jnv97ws6cizn9mi8zr9hcg7rixd0jg7smhdq8apacjb572"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -1804,7 +1804,11 @@  (define-public qtmultimedia
               ;; session bus, which requires an X11 server, and then is still
               ;; unhappy).
               (substitute* "tests/auto/CMakeLists.txt"
-                (("add_subdirectory\\(integration)") ""))))
+                (("add_subdirectory\\(integration)") ""))
+              ;; The "qvideoframecolormanagement" tests fail with an
+              ;; 'offscreen rendering' error.
+              (substitute* "tests/auto/unit/multimedia/CMakeLists.txt"
+                (("add_subdirectory\\(qvideoframecolormanagement\\)") ""))))
           (add-before 'check 'prepare-for-tests
             (lambda _
               (setenv "QT_QPA_PLATFORM" "offscreen")))