diff mbox series

[bug#67024,36/54] gnu: Add rust-gix-refspec-0.18.

Message ID cb36bbe85b28f7ae679931fa9c9eeaa4d158a2c1.1699556975.git.steve@futurile.net
State New
Headers show
Series Series to add StackedGit 2.4 | expand

Commit Message

Steve George Nov. 9, 2023, 7:38 p.m. UTC
* gnu/packages/crates-io.scm (rust-gix-refspec-0.18): New variable.

Change-Id: I358c2b562b5cc93840ffa42c29d51c9113495a3e
---
 gnu/packages/crates-io.scm | 37 +++++++++++++++++++++++++++++--------
 1 file changed, 29 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d73579a1f62..2697a4213f6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31875,8 +31875,36 @@  (define-public rust-gix-ref-0.30
     (description "This package provides a crate to handle git references.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-gix-refspec-0.18
+  (package
+    (name "rust-gix-refspec")
+    (version "0.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gix-refspec" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "07pniqh74kkm0n727m7wjxgrgwnaypljkhsh8nyw7wvh3rxwp588"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
+                       ("rust-gix-hash" ,rust-gix-hash-0.13)
+                       ("rust-gix-revision" ,rust-gix-revision-0.22)
+                       ("rust-gix-validate" ,rust-gix-validate-0.8)
+                       ("rust-smallvec" ,rust-smallvec-1)
+                       ("rust-thiserror" ,rust-thiserror-1))))
+    (home-page "https://github.com/Byron/gitoxide")
+    (synopsis
+     "This package provides parsing and representing refspecs to Gitoxide")
+    (description
+     "This package parses and represents Git refspecs.  It's part of Gitoxide
+a pure Rust implementation of Git.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gix-refspec-0.11
   (package
+    (inherit rust-gix-refspec-0.18)
     (name "rust-gix-refspec")
     (version "0.11.0")
     (source
@@ -31886,7 +31914,6 @@  (define-public rust-gix-refspec-0.11
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1x0cayswa8m0yiybi8g3jimpc6jggfvrw6y53snxhvf8mciddgvj"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-bstr" ,rust-bstr-1)
@@ -31894,13 +31921,7 @@  (define-public rust-gix-refspec-0.11
         ("rust-gix-revision" ,rust-gix-revision-0.15)
         ("rust-gix-validate" ,rust-gix-validate-0.7)
         ("rust-smallvec" ,rust-smallvec-1)
-        ("rust-thiserror" ,rust-thiserror-1))))
-    (home-page "https://github.com/Byron/gitoxide")
-    (synopsis "Parsing and representing refspecs")
-    (description
-     "This package provides a crate of the gitoxide project for parsing and
-representing refspecs.")
-    (license (list license:expat license:asl2.0))))
+        ("rust-thiserror" ,rust-thiserror-1))))))
 
 (define-public rust-gix-revision-0.22
   (package