diff mbox series

[bug#67024,01/54] gnu: Add rust-gix-hash-0.13.

Message ID 31851df5c182f6b0b9765363eb1ee993daf57313.1699556971.git.steve@futurile.net
State New
Headers show
Series Series to add StackedGit 2.4 | expand

Commit Message

Steve George Nov. 9, 2023, 7:37 p.m. UTC
* gnu/packages/crates-io.scm (rust-gix-hash-0.13): New variable.

Change-Id: I4d7e4a048efb463a019d01529622ad96c3a615d5
---
 gnu/packages/crates-io.scm | 41 +++++++++++++++++++++++++++++++-------
 1 file changed, 34 insertions(+), 7 deletions(-)


base-commit: bbec79fd55ba8efe4cb015bd07e4f40fb7d252d1
prerequisite-patch-id: bf5a485e0fa5c58fc612d3f3b3c1f964d4097d85
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 606ed5aa297..8c739575e1d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30865,8 +30865,34 @@  (define-public rust-gix-glob-0.8
 matching.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-gix-hash-0.13
+  (package
+    (name "rust-gix-hash")
+    (version "0.13.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gix-hash" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0q6c3jjp6q17w7879lwi7r1xw2zr489yk75yq4bm51x03sscg10q"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-document-features" ,rust-document-features-0.2)
+                       ("rust-faster-hex" ,rust-faster-hex-0.8)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-thiserror" ,rust-thiserror-1))))
+    (home-page "https://github.com/Byron/gitoxide")
+    (synopsis
+     "Borrowed and owned git hash digests used to identify git objects")
+    (description
+     "Borrowed and owned git hash digests used to identify git objects.  This
+package is part of Gitoxide, a pure Rust implementation of Git.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gix-hash-0.11
   (package
+    (inherit rust-gix-hash-0.13)
     (name "rust-gix-hash")
     (version "0.11.4")
     (source
@@ -30876,19 +30902,20 @@  (define-public rust-gix-hash-0.11
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "0bq986grpsfc6ddav5dlb8zvz1aky264dnnnmax2h1lsmpr2yhjb"))))
-    (build-system cargo-build-system)
+    ;(build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-document-features" ,rust-document-features-0.2)
         ("rust-hex" ,rust-hex-0.4)
         ("rust-serde" ,rust-serde-1)
         ("rust-thiserror" ,rust-thiserror-1))))
-    (home-page "https://github.com/Byron/gitoxide")
-    (synopsis
-     "Borrowed and owned git hash digests used to identify git objects")
-    (description
-     "Borrowed and owned git hash digests used to identify git objects.")
-    (license (list license:expat license:asl2.0))))
+    ;(home-page "https://github.com/Byron/gitoxide")
+    ;(synopsis
+    ; "Borrowed and owned git hash digests used to identify git objects")
+    ;(description
+    ; "Borrowed and owned git hash digests used to identify git objects.")
+    ;(license (list license:expat license:asl2.0))
+    ))
 
 (define-public rust-gix-hashtable-0.2
   (package