diff mbox series

[bug#67024,02/54] gnu: Add rust-prodash-26.

Message ID c30d319e0e11664bdbe2d61acd622dfa86c1e7cd.1699556971.git.steve@futurile.net
State New
Headers show
Series Series to add StackedGit 2.4 | expand

Commit Message

Steve George Nov. 9, 2023, 7:37 p.m. UTC
gnu/packages/crate-io.scm (rust-prodash-26): New variable.

Change-Id: I7c5dc1da92eff338376c6af68718eee85a190489
---
 gnu/packages/crates-io.scm | 62 ++++++++++++++++++++++++++++++++------
 1 file changed, 53 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8c739575e1d..78f04e11de3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56337,8 +56337,60 @@  (define-public rust-procedural-masquerade-0.1
 @code{proc_macro_derive} pretend to be @code{proc_macro}.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-prodash-26
+  (package
+    (name "rust-prodash")
+    (version "26.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "prodash" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1kxvsxyh79qz524vl0r50svga84fcax4ngpcvkf576yiwbw5njvr"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-async-io" ,rust-async-io-1)
+                       ("rust-bytesize" ,rust-bytesize-1)
+                       ("rust-compound-duration" ,rust-compound-duration-1)
+                       ("rust-crosstermion" ,rust-crosstermion-0.11)
+                       ("rust-ctrlc" ,rust-ctrlc-3)
+                       ("rust-dashmap" ,rust-dashmap-5)
+                       ("rust-futures-core" ,rust-futures-core-0.3)
+                       ("rust-futures-lite" ,rust-futures-lite-1)
+                       ("rust-human-format" ,rust-human-format-1)
+                       ("rust-humantime" ,rust-humantime-2)
+                       ("rust-is-terminal" ,rust-is-terminal-0.4)
+                       ("rust-log" ,rust-log-0.4)
+                       ("rust-parking-lot" ,rust-parking-lot-0.12)
+                       ("rust-ratatui" ,rust-ratatui-0.20)
+                       ("rust-signal-hook" ,rust-signal-hook-0.3)
+                       ("rust-time" ,rust-time-0.3)
+                       ("rust-tui-react" ,rust-tui-react-0.20)
+                       ("rust-unicode-segmentation" ,rust-unicode-segmentation-1)
+                       ("rust-unicode-width" ,rust-unicode-width-0.1))
+       #:cargo-development-inputs(("rust-argh" ,rust-argh-0.1) ; >0.1.3
+                                  ("rust-asyn-executor" ,rust-async-executor-1)
+                                  ("rust-async-io" ,rust-async-io-1)
+                                  ("rust-blocking" ,rust-blocking-1)
+                                  ("rust-criterion" ,rust-criterion-0.5)
+                                  ("rust-env-logger" ,rust-env-logger-0.10)
+                                  ("rust-futures" ,rust-futures-0.3)
+                                  ("rust-futures-util" ,rust-futures-util-0.3)
+                                  ("rust-is-terminal" ,rust-is-terminal-0.4)
+                                  ("rust-once-cell" ,rust-once-cell-1)
+                                  ("rust-rand" ,rust-rand-0.8))))
+    (home-page "https://github.com/Byron/prodash")
+    (synopsis
+     "Dashboard for visualizing progress of asynchronous and possibly blocking tasks")
+    (description
+     "This package provides a dashboard for visualizing the progress of asynchronous
+and possibly blocking tasks.")
+    (license license:expat)))
+
 (define-public rust-prodash-25
   (package
+    (inherit rust-prodash-26)
     (name "rust-prodash")
     (version "25.0.2")
     (source
@@ -56348,7 +56400,6 @@  (define-public rust-prodash-25
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1xva91iks58431asnsx3lfqyr4z4fvvkrc2b582llalr411fnrqx"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-async-io" ,rust-async-io-1)
@@ -56381,14 +56432,7 @@  (define-public rust-prodash-25
         ("rust-futures-util" ,rust-futures-util-0.3)
         ("rust-is-terminal" ,rust-is-terminal-0.4)
         ("rust-once-cell" ,rust-once-cell-1)
-        ("rust-rand" ,rust-rand-0.8))))
-    (home-page "https://github.com/Byron/prodash")
-    (synopsis
-     "Dashboard for visualizing progress of asynchronous and possibly blocking tasks")
-    (description
-     "This package provides a dashboard for visualizing progress of asynchronous and
-possibly blocking tasks.")
-    (license license:expat)))
+        ("rust-rand" ,rust-rand-0.8))))))
 
 (define-public rust-progress-0.2
   (package