[bug#64771,09/12] gnu: Add emacs-rebecca-theme.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-rebecca-theme): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Comments
Am Freitag, dem 21.07.2023 um 18:44 +0400 schrieb Ahmad Draidi:
> * gnu/packages/emacs-xyz.scm (emacs-rebecca-theme): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 9cbfae7c86..6e0d0053b2 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -3465,6 +3465,33 @@ (define-public emacs-read-only-cfg
> directories or regex patterns.")
> (license license:gpl3+))))
>
> +;; Use latest commit since there are no tags anymore for several
> versions
> +(define-public emacs-rebecca-theme
> + (let ((commit "4b8b5aae9099185e07c2b4cac4943c7f66a3f003")
> + (revision "0"))
> + (package
> + (name "emacs-rebecca-theme")
> + (version (git-version "1.3.2" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/vic/rebecca-theme")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> +
> "0y2kcs6zgi3dijagyz6lxbv6gi2mih8m943fhjrzkj35wfvjmhsz"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/vic/rebecca-theme")
> + (synopsis "Dark Emacs theme with purple/violet colors")
> + (description
> + "Rebecca Emacs theme is a dark theme with purple/violet
> colors, based on
> +the @code{Dracula} theme for Emacs and the @code{Gloom} theme for
> Atom.
> +
> +The author recommends @url{https://www.tumblr.com/liamwong, Liam
> Wong's}
> +photos as background with this theme.")
Removed the ad to some person's Tumblr. Pushed along with the rest of
the series.
Cheers
Hello,
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> Am Freitag, dem 21.07.2023 um 18:44 +0400 schrieb Ahmad Draidi:
>> + (description
>> + "Rebecca Emacs theme is a dark theme with purple/violet
>> colors, based on
>> +the @code{Dracula} theme for Emacs and the @code{Gloom} theme
>> for
>> Atom.
>> +
>> +The author recommends @url{https://www.tumblr.com/liamwong,
>> Liam
>> Wong's}
>> +photos as background with this theme.")
> Removed the ad to some person's Tumblr. Pushed along with the
> rest of
> the series.
Thanks for the merge. Just want to clarify the rationale behind
adding the wallpapers link (Tumblr). A theme is essentially
aesthetics, and the wallpapers are part of that, basically.
I trust your decision as a maintainer, of course.
For future packages, would it be acceptable to add something like
"Visit the theme's homepage for recommended wallpapers" or
something along those lines to highlight the recommendations
existence to the user?
>
> Cheers
Thanks
Hi Ahmad,
Am Sonntag, dem 30.07.2023 um 11:09 +0400 schrieb Ahmad Draidi:
> Thanks for the merge. Just want to clarify the rationale behind
> adding the wallpapers link (Tumblr). A theme is essentially
> aesthetics, and the wallpapers are part of that, basically.
> I trust your decision as a maintainer, of course.
Aesthetics are highly subjective and while recommending wallpapers on
your own website is quite fine, doing so in the context of a free
software package manager (especially directing people to non-free
platforms) is a very different thing. I'm not even sure whether those
wallpapers would be CC licensed because Tumblr failed to load for me
when I checked, which for me is reason enough to drop the
recommendation.
Cheers
Thanks a lot for the explanation and your patience.
@@ -3465,6 +3465,33 @@ (define-public emacs-read-only-cfg
directories or regex patterns.")
(license license:gpl3+))))
+;; Use latest commit since there are no tags anymore for several versions
+(define-public emacs-rebecca-theme
+ (let ((commit "4b8b5aae9099185e07c2b4cac4943c7f66a3f003")
+ (revision "0"))
+ (package
+ (name "emacs-rebecca-theme")
+ (version (git-version "1.3.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vic/rebecca-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y2kcs6zgi3dijagyz6lxbv6gi2mih8m943fhjrzkj35wfvjmhsz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/vic/rebecca-theme")
+ (synopsis "Dark Emacs theme with purple/violet colors")
+ (description
+ "Rebecca Emacs theme is a dark theme with purple/violet colors, based on
+the @code{Dracula} theme for Emacs and the @code{Gloom} theme for Atom.
+
+The author recommends @url{https://www.tumblr.com/liamwong, Liam Wong's}
+photos as background with this theme.")
+ (license license:expat))))
+
(define-public emacs-bbdb
(package
(name "emacs-bbdb")