[bug#64771,08/12] gnu: Add emacs-treemacs-nerd-icons.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-treemacs-nerd-icons): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
@@ -29599,6 +29599,33 @@ (define-public emacs-treemacs-extra
emacs-perspective
mu)))))
+;; Package has no releases or tags. Version is extracted from "Version:"
+;; keyword in main file.
+(define-public emacs-treemacs-nerd-icons
+ (let ((commit "8ddd94661ab9f3c9094dd4b5632bcdd57bdf871d")
+ (revision "0"))
+ (package
+ (name "emacs-treemacs-nerd-icons")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/rainstormstudio/treemacs-nerd-icons")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dlp1wqjapcn7d6s2c6c43fap2sw5kb1qbvm28jq22k1h8k77632"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nerd-icons emacs-treemacs))
+ (home-page "https://github.com/rainstormstudio/treemacs-nerd-icons")
+ (synopsis "Treemacs nerd-icons icon theme")
+ (description
+ "This package provides an icon theme for @code{treemacs} using
+@code{nerd-icons}.")
+ (license license:gpl3+))))
+
(define-public emacs-libyaml
;; Upstream made no release so far.
(let ((version "0.1")