diff mbox series

[bug#64771,11/12] gnu: Add emacs-chocolate-theme.

Message ID 6359f33c1ca197f309c9c03cc46099f9e488056b.1689948588.git.a.r.draidi@redscript.org
State New
Headers show
Series Add and update a bunch of Emacs packages | expand

Commit Message

Ahmad Draidi July 21, 2023, 2:44 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-chocolate-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1126907f8b..13fb414be0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4174,6 +4174,31 @@  (define-public emacs-caps-lock
 Lock key.")
     (license license:gpl3+)))
 
+(define-public emacs-chocolate-theme
+  (let ((commit "ccc05f7ad96d3d1332727689bf6250443adc7ec0")
+        (revision "0"))
+    (package
+      (name "emacs-chocolate-theme")
+      (version (git-version "0.2.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url
+                       "https://github.com/SavchenkoValeriy/emacs-chocolate-theme")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1d8a9jwv9y0sncw24k840c8yyrig30f2d6q2zqlc09f05yzq9p9p"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-autothemer))
+      (home-page "https://github.com/SavchenkoValeriy/emacs-chocolate-theme")
+      (synopsis "Dark chocolatey theme for Emacs")
+      (description
+       "Chocolate theme is a dark, chocolatey, vibrant and subtle theme for
+Emacs.")
+      (license license:gpl3))))
+
 (define-public emacs-chronometrist
   (package
     (name "emacs-chronometrist")