diff mbox series

[bug#65037,3/7] gnu: Add python-construct-classes.

Message ID bb48c5610a881a10e8e7ea8e80451991418e271a.1691068294.git.attila@lendvai.name
State New
Headers show
Series [bug#65037,1/7] gnu: python-daemon: Use the git repo as source instead of pypi. | expand

Commit Message

Attila Lendvai Aug. 3, 2023, 1:11 p.m. UTC
* gnu/packages/python-xyz.scm (python-construct-classes): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 20e19ce4f2..309dd3be20 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -803,6 +803,31 @@  (define-public python-colorful
 as functions or string constants to form colored terminal output.")
     (license license:expat)))
 
+(define-public python-construct-classes
+  (package
+    (name "python-construct-classes")
+    (version "0.1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/matejcik/construct-classes")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fmr8nfg543lyqk4164a52jb6lwpq98radicbkhhdfckq9lib2wp"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-construct))
+    (native-inputs
+     (list python-poetry-core
+           python-pytest))
+    (home-page "https://github.com/matejcik/construct-classes")
+    (synopsis "Parse binary structs into dataclasses")
+    (description "This package provides a parser to parse binary structs
+into dataclasses.")
+    (license license:expat)))
+
 (define-public python-yaspin
   (package
     (name "python-yaspin")