diff mbox series

[bug#65037,5/7] gnu: python-trezor-agent: Update to 0.14.7.

Message ID 269bf6a9ec59b1974ccefa551b162bdb31ab8b5b.1691068294.git.attila@lendvai.name
State New
Headers show
Series [bug#65037,1/7] gnu: python-daemon: Use the git repo as source instead of pypi. | expand

Commit Message

Attila Lendvai Aug. 3, 2023, 1:11 p.m. UTC
---
 gnu/packages/finance.scm | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 2d28de0ee4..0656d72e64 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -923,7 +923,7 @@  (define-public python-trezor-agent
   ;; the toplevel app called trezor-agent.
   (package
     (name "python-trezor-agent")
-    (version "0.14.4")
+    (version "0.14.7")
     (source
      (origin
        (method git-fetch)
@@ -932,7 +932,7 @@  (define-public python-trezor-agent
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1ksv494xpga27ifrjyn1bkqaya5h769lqb9rx1ng0n4kvmnrqr3l"))))
+        (base32 "04dds5bbw73nk36zm8d02qw6qr92nrlcf8r1cq8ba96mzi34jbk0"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -960,8 +960,12 @@  (define-public python-trezor-agent
            python-semver
            python-unidecode
            python-wheel))
-    (native-inputs
-     (list gnupg python-mock python-pytest))
+    (native-inputs ; Only needed for running the tests
+     (list gnupg
+           python-bech32
+           python-cryptography
+           python-mock
+           python-pytest))
     (home-page "https://github.com/romanz/trezor-agent")
     (synopsis "Use hardware wallets as SSH and GPG agent")
     (description