diff mbox series

[bug#65037,7/7] gnu: trezord: Update to 2.0.33.

Message ID 03db3fa511b9aa164be15d3ccfd2eb47b366f02d.1691068294.git.attila@lendvai.name
State New
Headers show
Series [bug#65037,1/7] gnu: python-daemon: Use the git repo as source instead of pypi. | expand

Commit Message

Attila Lendvai Aug. 3, 2023, 1:11 p.m. UTC
* gnu/packages/finance.scm (trezord): Update version and hash, specify go-1.20
as the compiler.  Mention in a comment that the minimal requirement is 1.18.
---
 gnu/packages/finance.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 807241ab8c..8a62ac2805 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1660,7 +1660,7 @@  (define-public trezord-udev-rules
 (define-public trezord
   (package
     (name "trezord")
-    (version "2.0.31")
+    (version "2.0.33")
     (source
      (origin
        (method git-fetch)
@@ -1668,11 +1668,13 @@  (define-public trezord
              (url "https://github.com/trezor/trezord-go")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "130nhk1pnr3xx9qkcij81mm3jxrl5zvvdqhvrgvrikqg3zlb6v5b"))
+        (base32 "0nnfh9qkb8ljajkxwrn3nn85zrsw10hp7c5i4zh60qgfyl0djppw"))
        (file-name (git-file-name name version))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/trezor/trezord-go"))
+     `(#:import-path "github.com/trezor/trezord-go"
+       ;; Requires go 1.18 or later: https://github.com/trezor/trezord-go/commit/f559ee5079679aeb5f897c65318d3310f78223ca
+       #:go ,go-1.20))
     (native-inputs
      `(("github.com/gorilla-csrf" ,go-github-com-gorilla-csrf)
        ("github.com/gorilla/handlers" ,go-github-com-gorilla-handlers)